Qt tests errors



  • Hello,

    I will certainly begin to contribute to Qt and I'm trying to run the autotests before to continue. When I run the tests I got some fails (for example 21 fails for tst_QCollator) and then an error and it breaks. Here is the end of the output :

    ...
    QWARN  : tst_QCollator::compare(french5) Only default locale supported with the posix collation implementation
    FAIL!  : tst_QCollator::compare(french5) Compared values are not the same
       Actual   (collator.compare(s1, s2)): 8
       Expected (result)                  : -1
       Loc: [tst_qcollator.cpp(176)]
    PASS   : tst_QCollator::state()
    PASS   : tst_QCollator::cleanupTestCase()
    Totals: 12 passed, 21 failed, 0 skipped, 0 blacklisted, 1ms
    ********* Finished testing of tst_QCollator *********
    Makefile:1238: recipe for target 'check' failed
    make[6]: *** [check] Error 21
    make[6]: Leaving directory '/home/user/qt5/qtbase/tests/auto/corelib/tools/qcollator'
    Makefile:4436: recipe for target 'sub-qcollator-check' failed
    make[5]: *** [sub-qcollator-check] Error 2
    make[5]: Leaving directory '/home/user/qt5/qtbase/tests/auto/corelib/tools'
    Makefile:1733: recipe for target 'sub-tools-check' failed
    make[4]: *** [sub-tools-check] Error 2
    make[4]: Leaving directory '/home/user/qt5/qtbase/tests/auto/corelib'
    Makefile:1806: recipe for target 'sub-corelib-check' failed
    make[3]: *** [sub-corelib-check] Error 2
    make[3]: Leaving directory '/home/user/qt5/qtbase/tests/auto'
    Makefile:1064: recipe for target 'sub-auto-check' failed
    make[2]: *** [sub-auto-check] Error 2
    make[2]: Leaving directory '/home/user/qt5/qtbase/tests'
    Makefile:1641: recipe for target 'sub-tests-check' failed
    make[1]: *** [sub-tests-check] Error 2
    make[1]: Leaving directory '/home/user/qt5/qtbase'
    Makefile:3207: recipe for target 'module-qtbase-check' failed
    make: *** [module-qtbase-check] Error 2
    

    I think that the fails on some tests might be normal but the errors stop the tests.
    I ran it with "make -j1 check". Is it normal or am I doing something wrong ?
    Thank you in advance :)

    Edit : Ok I ran with -k option, I understand that it breaks because of the fail but I have 55 tests that failed and I can't find if it is normal or not.



  • Make sure that your Qt is built with ICU support



  • Thank you, it works for this error.
    So if it works for that I suppose there is a way to solve all errors. I will try to find the solution.


Log in to reply