QVNCServer of QT app can't be connected by Vncviewer



  • I cross compiled QT4.8 with -qt-gfx-vnc, and it succeed. when I run my app in VNC mode

    ./app/DIalogCam-4.8.5 -qws -display "VNC::size=640*480:de
    ./app/DIalogCam-4.8.5 -qws -display VNC:0
    both forms

    it showed "QVNCServer created on port 5900" and without any error
    but Vncviewer in pc keeps connecting....no response

    I also try to set vncviewer's colorlevel, but still no work. I messed up with this problem for 2 days, I think it runs, maybe somewhere setting not right?

    hope your idea or some suggestions


  • Lifetime Qt Champion

    Hi,

    The first thing I'd do is to rather use the latest version of Qt 4 which is Qt 4.8.7 or even better move to Qt 5. The latest Qt 5 version have VNC backend.

    As for your problem, you should try to use wireshark to see if there's something wrong network side.



  • I did try to have VNC feature enabled in my application which was built on Qt 4.8.4 and I could succeed.

    I am not sure about the root cause but it looks like you don't have ping. Your VNC Client is not talking to VNC server. May be that your VNC client is not looking at the right port?
    And may be a quick test to do is try to change the VNC port? May be display VNC:1?


Log in to reply