Beaglebone black hang when "reading u-boot.img"



  • hello guys
    I am building boot2qt image for beaglebone black (BBB) using Yocto. I made the following steps:
    Notes: I followed http://elinux.org/Beagleboard:BeagleBone_Black_Serial to setup serial debug and my host is Ubuntu 16.04LTS x64

    My build was successful. But when I wrote b2qt-embedded-qt5-image-beaglebone.img to sdcard, and then plug-in into beagblebone black board.

    • press "S2" button on board, then power on

    Beaglebone black hang when "reading u-boot.img"
    On screen it only show some lines of message as follow:
    " U-Boot SPL 2017.01-g8369eec4f3 (Apr 15 2017 - 05:09:59)
    Trying to boot from MMC1
    *** Warning - bad CRC, using default environment

    reading u-boot.img
    reading u-boot.img "
    please show me how to solve it.


  • Lifetime Qt Champion

    Hi,

    Boot2Qt being a licensed product, I'd recommend contacting The Qt Company directly for that problem.



  • Thanks for your response, SGaist
    But I am seeking other solution than contacting The Qt company.
    In other hands, contacting the Qt company is difficult. I tried contacting with them very much times about requesting qt device creation trial. But so far I still don't receive their response.


  • Lifetime Qt Champion

    In which region are you ?



  • I am in Vietnam, Asian south-eastern region.


  • Lifetime Qt Champion

    @tekojo can you take a look at this ?


  • administrators

    Sure.
    Hi @rocket42 when did you try contacting The Qt Company for an evaluation?
    I'll ask around who in Asia should be getting back to you, but it helps if there is a date.



  • hi @tekojo ,
    I can't remember date exactly. I contacted using your form.
    I used my email "hung.rocket42@gmail.com" to contact. I hope receive your response about qt device creation evaluation as soon as possible. Thanks


Log in to reply