QOpenGLFramebufferObject: Unsupported framebuffer format on Quadro FX 560



  • Hello everyone

    We are working on systems that bear a Quadro FX 560. After the update of the Qt program that runs on it, one of the system had these warnings that kept appearing :
    [11:26:56] QOpenGLFramebufferObject: Unsupported framebuffer format.
    [11:26:56] QOpenGLFramebufferObject: Unsupported framebuffer format.
    [11:26:56] QOpenGLFramebufferObject: Framebuffer incomplete attachment.

    We have identified the part of the code that generates the problem. So we got that going.
    Now the problem is that somehow, the problem on the system has disappeared overnight. No more warnings the next morning.

    The only changes that were done on the system were the following :

    • In the nvidia control panel, the global preset has been changed from "3D App - Game Development" to "Base Profile"
    • The Qt libraries in the soft have been updated. The soft has been launched (the problem was still there). Then the libraries have been changed back.
    • The driver has not been changed

    These are the only modifications done on the system. Do you think any of these could have solved the problem ?
    We have tried many things and we cannot recreate the framebuffer issue. This is a bit of a problem if we want to develop a patch for our Qt code.

    Any help is most welcome.


  • Lifetime Qt Champion

    Hi,

    You are not giving crucial informations:

    • What version of Qt are you using ?
    • Which one gave you the warning ?
    • Which not ?
    • Are you using a custom build of Qt ?
    • What OS are you on ?
    • Version of the nVidia driver ?

Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.