How to install Qt5.7+ on TX1



  • Hi everyone,
    I'm trying to install Qt5.7 (or newer) on the Jetson TX1.
    5.7 or up since I need to run Qt Controls 2.

    https://blog.qt.io/blog/2016/11/10/qt-nvidia-jetson-tx1-device-creation-style/
    gives hint for cross-compilation, but it fails here (from what I understand, this is because the JetPack install method has changed).
    Anyway what I'm looking for is compilation on the device itself.

    Has someone been able to install Qt 5.7 on the TX1 (or on a host with the TX1 as a target device)?
    If so, how?

    I'm no Linux expert but just some design/coding guy.
    I've tried to download qtbase and compile it, but ./configure will end with an error (missing folders).
    I've also added Linaro gcc arch64, same result.
    Used hours and hours to search and try ... no luck as of now.
    Help is needed!
    In case Laszlo would come by, I'm pretty sure he'd know the answers...


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    What distribution are you running on the TX1 ?

    What error did you got ?



  • Sorry, had not put under watch ...

    Thanks for your reply.

    I've ended with a successful compilation of Qt5.8.1 on the TX1.
    There is a very strict order of sudo apt-get install to be followed on a freshly flashed TX1.
    For QtCreator4.2 it's kind of a nightmare but also went through.

    However, my compilation did not include QtWebEngine, which always failed during compilation.
    Each compilation is of about 6-8 hours, so I gave up.
    But now I need QtWebEngine, so my new question there: https://forum.qt.io/topic/77073/adding-qtwebengine-after-initial-qt5-8-build-plug-in-not-installed

    Cheers!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.