EGLFS app keyboard input



  • Hi all,

    My application runs on raspberry (raspbian jessie) with QT version 5.5.1. It is a fullscreen EGLFS app.

    But the thing is that the keyboard input doesn't work. As soon as the application starts (QT fullscreen EGLFS application), the keyboard stops reacting to the input. At least that's what I observe. From that point I cannot even toggle caps lock or num lock. The application itself is however not frozen or anything, it still reacts to the GPIO input.

    I am not that much interested in the keyboard input itself but I need to be able to close the application somehow...

    Before, I was using 5.2 binaries with raspbian wheezy and I could quit the application and return to shell by hitting Ctrl+C. I had never had a real keyboard input but that in fact doesn't matter as long as I could quit the app in any way (using keyboard). Whatever I pressed on the keyboard is directed to the terminal because when I quit the app (Ctrl+C) I could see the input I had typed there.

    To summarize:
    I use eventFilter for to get key presses.

    • On my Windows dev machine, I have no problem and I get the keyboard input.
    • On QT5.2 on wheezy my input was directed to terminal and not to my application, but Ctrl+C was working and I could close the app.
    • On QT5.5.1 on jessie my inpit is directed to terminal and not my app and I cannot even use Ctrl+C to close the app.

    I have tried setting some environment variables as described in here in the section input:
    http://doc.qt.io/qt-5/embedded-linux.html

    ...but with no luck. The main problem is probably the fact that I don't really know what I'm doing.

    Thanks!



  • I found this thread:
    https://forum.qt.io/topic/47830/solved-no-input-on-linuxfb-and-eglfs

    It has a different goal but between the lines there was sitting an answer to my question:
    QT_QPA_ENABLE_TERMINAL_KEYBOARD

    I have tried this option before and it didn't help but the problem was that the variable was set after the program was executed (because yet again, I was confused with the order in which the shell configuration scripts get executed...).


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.