[Solved] No input on linuxfb and eglfs



  • Hi,
    I have some problems with getting input when using linuxfb or eglfs as platform in my applications.

    I tried to follow the instructions from this site: http://qt-project.org/doc/qt-5/embedded-linux.html

    I have a Compulab Utilite i.MX6 based computer. I compiled QT locally (no cross-compilation) with egl2 support using the -device imx6 switch (as described here: http://qt-project.org/wiki/i.MX-6).

    The QT programs are working as expected when executed on X11 (using -platform xcb switch). However they don't accept any input when running on linuxfb or eglfs platform (ran without X server).

    The libudev is installed, so the keyboard and mouse should be discoverable. The programs are running (the clock in the digiflip example is updating the actual time), but there is no way to interact with them.

    I tried to set the QT_QPA_GENERIC_PLUGINS=evdevkeyboard,evdevmouse environment variable, to run the app with -plugin evdevkeyvoard -plugin evdevmouse parameters, even to specify the device address from the /dev folder. I don't even have a mouse cursor appearing. There is no way to close the program, except restarting the computer (unless I set the QT_QPA_ENABLE_TERMINAL_KEYBOARD to 1, in which case I can close the application with Ctrl-C).

    What am I doing wrong?
    Any help is much appreciated!



  • EGLFS and LinuxFB both require permissions to /dev/input/event?
    Either run the application as sudo or change the permissions on the input files.



  • Thanks, this solved the issue :)
    Both ideas are working.

    Just one more question: is there any simple way to close the program in these cases, or I must create a button or key combination to do this?



  • I changed permissions and also set the GENERIC_PLUGINS
    but still i dont see keyboard or mouse in a simple quick 2 gui in raspberry pi 3
    any ideas?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.