Congratulations to our 2022 Qt Champions!

PlatformInputContext plugin does not load

  • Hi,

    I have compiled the Virtual keyboard plugin based on

    for my ARM target. It worked fine on my Ubuntu desktop. On target, the plugin is not getting loaded.
    I tried to debug with 'export QT_DEBUG_PLUGINS=1'. There are two problems.

    1. My /usr/lib/qt5/plugins/platforminputcontexts/ is not searched for the plugin at all.

    2. I copied the contents of the above folder to another folder where other plugin was loaded. Then I found the following in the traces:

    "IID": "org.qt-project.Qt.QPlatformInputContextFactoryInterface",
    "MetaData": {
    "Keys": [
    "className": "VirtualKeyboardInputContextPlugin",
    "debug": false,
    "version": 328449
    Got keys from plugin meta data ()

    I am not sure why the Got keys value is empty. On Desktop this shows the value 'freevirtualkeyboard'.


  • Lifetime Qt Champion

    @Vinoth What is not clear: do you try to use the same lib on your ARM device which you use on your host?

  • Yes, I am trying to use the same lib for my ARM device, after compiling the library for my ARM device.

Log in to reply