QtWayland on Yocto: Compilation error on accessibility method



  • Hi,

    I'm using meta-qt5 (Qt 5.7.0) with Yocto 2.2 (Morty).
    Most of Qt projects compile except QtWayland.
    the error I get is this one:

    moc /home/borne/Projects/poky2/build-toaster-2/tmp/work/corei7-64-poky-linux/qtwayland/5.7.0+gitAUTOINC+a172672484-r0/git/src/client/qwaylandwlshellsurface_p.h
    In file included from ../../include/QtWaylandClient/5.7.0/QtWaylandClient/private/qwaylandintegration_p.h:1:0,
                     from /home/borne/Projects/poky2/build-toaster-2/tmp/work/corei7-64-poky-linux/qtwayland/5.7.0+gitAUTOINC+a172672484-r0/git/src/client/global/qwaylandclientextension_p.h:53,
                     from /home/borne/Projects/poky2/build-toaster-2/tmp/work/corei7-64-poky-linux/qtwayland/5.7.0+gitAUTOINC+a172672484-r0/git/src/client/global/qwaylandclientextension.cpp:38:
    ../../include/QtWaylandClient/5.7.0/QtWaylandClient/private/../../../../../../git/src/client/qwaylandintegration_p.h:97:29: error: 'QPlatformAccessibility* QtWaylandClient::QWaylandIntegration::accessibility() const' marked 'override', but does not override
         QPlatformAccessibility *accessibility() const Q_DECL_OVERRIDE;
                                 ^~~~~~~~~~~~~
    

    I have no idea how to fix this. I tried solutions seen on forums but it didn't change anything.
    Does any one have an idea how to make it compile ?

    Thanks in advance


  • Lifetime Qt Champion

    Hi,

    The quick and dirty fix is to remove the Q_DECL_OVERRIDE keyword on the line triggering the error.



  • QtWayland isn't the only part which doesn't compile because of accessibility problems.
    Removing the keyword manually isn't the solution I was expecting but it's a working one.
    Thank you.

    If any one come with a better solution, feel free to answer the post.


  • Lifetime Qt Champion

    Update to at least 5.7.1, there was a fix for that accessibility build error. The feature was not correctly handled.

    Where else did you encounter that problem ?



  • I encounter the same problem while trying to compile QtCreator. Instead that this time, accessibility wasn't the only origin.
    I also have a crash on the webengine (runtime) but as nothing to do with accessibility.

    With meta-qt5, it is difficult to find out which version it's using (5.7.0 or 5.7.1).
    I tried to move from the branch 'morty-16.0.0' to the branch 'morty' (more recently updated). I still have the same problem.
    On which branch is yocto using meta-qt5 in with Qt 5.7.1 ?


  • Lifetime Qt Champion

    From a quick look at qt5-git.inc from morty it seems to be 5.7.0



  • Well, I tried to upgrade the version to 5.7.1 by overloading the version value. I also tried to change manualy branches. None of this work.
    I'm stuck.
    I guess I will for get about using Qt on Yocto for now and come back when a new version is available.
    Thanks for the help !


  • Lifetime Qt Champion

    5.8 being around the corner, it might be worth checking it.

    You're welcome !


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.