Broken text in Qt Creator UI



  • Sometimes (not always), certain text items in the Qt Creator UI are broken:

    Broken text in Qt Creator UI

    Any idea what causes it? Or a workaround?

    Maybe the problem is my cheap video card (an Intel on-board one). This theory is supported by the fact that Creator is probably QML-powered by now, meaning it's running on OpenGL.

    I tried restarting Creator and that fixed it, but after switching between the Welcome and Edit tabs a few times, it happens again.

    I tried making Creator's UI use the software QML renderer, rather than OpenGL, as that might have made it work correctly. I did it by running the following in cmd.exe:

    > set QMLSCENE_DEVICE=softwarecontext
    > qtcreator.exe
    

    But that didn't fix it.



  • From the documentation when building Qt on Windows:

    For Qt Quick 2 to work, a graphics driver that provides OpenGL 2.1 or higher is required. The default driver from Windows is OpenGL 1.1. Qt includes a version of the ANGLE project which is included from the Windows Qt installers. ANGLE implements the OpenGL ES 2.0 API on top of DirectX 11 or DirectX 9. ANGLE requires that the DirectX SDK is installed when building Qt.

    Perhaps you could check which OpenGL driver you have and when needed install a driver for OpenGL 2.1 or higher?


  • Qt Champions 2016

    Hello,
    Do you observe similar behavior for other Qt based applications (if you have any on hand) or is this isolated to Qt Creator?



  • And while you at it, when the text is broken and you minimize and maximize QtCreator (or an other Qt based application), is the text then restored?

    Yeah, sounds silly, but perhaps you are experiencing something similar as I do.



  • @Jan-Willem said:

    Perhaps you could check which OpenGL driver you have and when needed install a driver for OpenGL 2.1 or higher?

    My driver supports exactly OpenGL 2.1 so that shouldn't be the problem. Also I have the latest drivers (although they're from 2012).

    @kshegunov said:

    Do you observe similar behavior for other Qt based applications (if you have any on hand) or is this isolated to Qt Creator?

    Well, I don't know what framework most of my Windows apps use, but I do use VLC Media Player, MuseScore and KWrite.
    VLC and KWrite (Windows version) use Qt4 and not Qt5 though.
    I have observed no such problems in these apps.

    @Jan-Willem said:

    And while you at it, when the text is broken and you minimize and maximize QtCreator (or an other Qt based application), is the text then restored?

    Well, that might fix it, but it will be only a temporary fix so not very useful.

    Thanks guys!



  • Yes, I know that minimizing and maximizing is a temporary fix and not a solution.
    But knowing this behaviour could help in getting to the core of the problem.

    Since you have QtCreator, you could build some of the examples and you can test if other Qt based applications have similar behavior.



  • @Jan-Willem: Thank you for the continued help, but I managed to get it fixed so I'm not going to debug it further. I have posted the solution here on StackOverflow. :)



  • Glad to see you have you're problem fixed.



Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.