Qt Creator Android Kit for x86 Devices



  • Hello,

    I want to use x86 Android emulator for speed. But x86 emulator is not suitable for my project it says.

    In Qt versions tab in tools, there are Qt 5.7.0 for Android armv7 and Qt 5.7.0 GCC 64bit

    In kits tab, there are same auto-detected options like above compilers. When i try to add new kits with these options:

    • Device Type: Android Device
    • Compiler: Android GCC (x86 64-4.9)
    • Qt Version: Qt 5.7.0 GCC 64bit

    Error says "Compiler cannot produce code for Qt version." and warning says "Device type is not supported by Qt version"

    Probably I should download true Qt version for Android x86 but i dont know how to do.

    I found this link but i couldn't install it: https://download.qt.io/online/qtsdkrepository/linux_x64/android/qt5_57/qt.57.android_x86/

    Also my system is Ubuntu 14.04 64bit. I installed Qt from full binary not online installer.


  • Moderators

    @maydin You need to install Qt for Android x86.
    Qt 5.7.0 GCC 64bit - this one is for desktop
    You can use Qt Maintenance Tool to add Android x86 version.



  • @jsulm Yeah I also tried that tool but somehow I cant see proper Android version there. Here the maintenance tool, as you can see next button is disabled because everything was installed.

    http://imgur.com/a/OCGDt

    When I run the tool first time there were no repository, I added from settings and then I saw above options.

    I also tried to add several different repositories there but that options does not change. I think there is a problem in maintenance tool. Because when I go settings I can not see any repositories added before.


  • Moderators

    @maydin Thats really strange. You should see many Qt versions not only 5.7 and Android x86 should be under 5.7. Did you install offline Qt package or did you use the online installer?



  • @jsulm I installed offline Qt package. But I opened that install binary again and I saw x86 for Android option unselected by default. I choose it only and installed to a fake directory. Then I copied related x86 folder to my real Qt directory.

    I solved this problem with this way. Now I can see the kit for x86 Android devices.

    Still I have problems running emulator but I think "just this" topic has been solved.

    Also can not find built APK file anywhere.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.