Where's my bundle .plist file?



  • I am using qmake to generate an iOS Xcode project. I am using a custom .plist file which is copied into the bundle as Info.plist in the resulting bundle. However, the custom .plist file is not included in my project view when I load it into Xcode. Here is the way I am setting up the custom .plist file to be incorporated into the build

    QMAKE_INFO_PLIST = tap_display.plist
    

    I see the file listed in the Build Settings->Packaging page, and its correct in the bundle, but I want it included in the Supporting Files section in my project view, so I can edit it in Xcode.

    I appreciate any help!



  • I found one solution. I added the custom .plist file to my OBJECTIVE_SOURCES list. This at least puts the file in the project view, and I was able to edit it via Xcode. I would prefer that the file were put in the "proper" location, as it would be if I were to create the project natively in Xcode.


  • Lifetime Qt Champion

    Hi,

    IIRC, you should take a look at OTHER_FILES for that.



  • Open .xcodeproj file by double clicking it. This will open Xcode. Go to the Build Settings tab. In the packaging you will find the path for your .plist file.

    PS. The xcodeproj file is located inside build folder of your project.



  • @NickV The whole problem is that the resulting Xcode project file does NOT contain the custom .plist file. Without that, I could not figure out how to edit it via Xcode. I need to use Xcode because the .plist parameter I am adding is custom for the third-party framework I am using, and hand-editing the file is not going to work since I don't know the internal representation of the resulting change. My previously posted solution solved that problem. I am left with a minor nit of getting the file in the proper place.



  • @SGaist Unfortunately that did not work. For now, I'm going to mark this as solved as my previous fix is good enough for now.

    Thanks!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.