Shadow build failure for iOS



  • I have an iOS project that builds in Qt Creator up until the point where the Settings.bundle is to be created. It first fails with Root.plist with an error: "No such file or directory". I check the path indicated and sure enough, the file is not there. I manually copied it over from my source tree and tried again. This time, it complains about Root.strings, etc.. none of the bundle files are in the shadow build location.

    This only happens when I do a shadow build.

    Is there something I'm missing in setting up my project that would ensure that these files get copied over for shadow builds, or is there another solution?

    Thanks!



  • I solved the problem on my own. I was not setting the path to the Root.plist file:

    SETTINGS_BUNDLE_DATA_ROOT.file += Root.plist
    SETTINGS_BUNDLE_DATA_ROOT.path += Settings.bundle
    

    When not doing a shadow build, the current path is the same. With a shadow build that is not the case, and the file does not exist at that location. This solved the problem:

    SETTINGS_BUNDLE_DATA_ROOT.file += $$PWD/Root.plist
    SETTINGS_BUNDLE_DATA_ROOT.path += $$PWD/Settings.bundle
    

    Silly me.



  • The interface won't let me mark this topic as SOLVED


  • Lifetime Qt Champion

    Hi,

    Because you didn't ask a question ;)

    Click on the "Topic Tools" button, there you'll see "Ask as question", then click again and you should get the usual mark as solved stuff.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.