From 10:00 CET Friday 22nd November we will adjust how the server works to deal with some recently reported problems. Therefore there may be a load problem, if you experience more problems than usual trying to access the forum then please PM AndyS or any of the moderators so they can inform me.


QML 5.7 QNX, module (or version) is not installed



  • Hello,

    I'm currently working on Qt 5.7 with QtWebKit compiled for QNX arm v7, I tested several QML applications, but I still have some troubles with two modules "QtQuick.VirtualKeyboard" and "QtWebKit" on i.MX6.

    First I copied the libraries to my i.MX6 target

    qt5.7
    |- lib
    |- plugins
    |- qml
    |- translations
    

    In the qml folder the two modules seems to be present

    qml
    |- ...
    |- QtQuicks
    |  |- ...
    |  |- VirtualKeyboard
    |  |  |- plugins.qmltypes
    |  |  |- qmldir
    |  |  |- Styles
    |  |     |- libqtvirtualkeyboardstylesplugin.so
    |  |     |- plugins.qmltypes
    |  |     |- qmldir
    |  |
    |  |- ... 
    |  
    |- ...
    |- QtWebKit
    |  |- libqmlwebkitplugin.so
    |  |- plugins.qmltypes
    |  |- qmldir
    |
    |- ...
    
    

    Qt paths are set on the target:

    QML_IMPORT_PATH=/opt/qt5.7/qml
    QML2_IMPORT_PATH=/opt/qt5.7/qml
    QT_PLUGIN_PATH=/opt/qt5.7/plugins
    LD_LIBRARY_PATH=<miscLibPaths>:/opt/qt5.7/lib
    QT_QPA_FONTDIR=/opt/qt5.7/lib/fonts
    

    For the first module I compiled the virtualkeyboard example provided by Qt, this works on Linux 32 bits Dekstop, but when you load it in the QNX i.MX6.target, it does not lauch and display an error module "QtQuick.VirtualKeyboard" is not installed. The code used in the qml file is import QtQuick.VirtualKeyboard 2.1

    For the second module I tried to make a custom Flickable WebView, this also works on Linux 32 bits Dekstop, but there is a similar problem on the QNX i.MX6.target, it does not lauch and display an error module "QtWebKit" version 3.0 is not installed, here it does not found this specific version of the module. The code used in the qml file is import QtWebKit 3.0
    Before that I already developped a QWebView widget also based on QtWebkit in another application to check HTML page display and it works both on Linux 32 bits Dekstop and QNX i.MX6.target. By the way this issue with QtWebKit on QML also impact Qt 5.6 LTS compiled for QNX arm v7.

    I tried fo found information on the forums and Qt website but i don't really undertsand what I am missing about the imports. I also search for information about Qt supported features on QNX but the only page I was able to found is Qt status on QNX and there is no specific version "updates" after Qt 5.4

    Thanks


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    I'd recommend bringing this question to the interest mailing list. You'll find there Qt's developers/maintainers. This forum is more user oriented.



  • Hello @SGaist,

    Thanks for the tip I will post also on the interest mailing list.

    Nevertheless I did not modified the qt sources and builds were working fine after compilation for Linux 32 bits and QNX, I just had to add QtWebKit from the community release because it is not a part of official release anymore.

    Actually for QtWebkit on QNX, the app seems have found the module but not the proper version (3.0). For Virtual Keyboard I did nothing more than compiling and try to use the exemple provided with Qt sources, first on Linux 32 bits then on my QNX arm v7 target. I did that with several others QML examples also provided with Qt sources and I did not encounter that kind of behaviour, no other modules where missing.

    Maybe i missed something on my target configuration (libs install, Path, ...), I just would like to know if there is a way to list which modules and version are properly installed on a specific system (Linux, QNX).