is it possible to run phonon player in arm based processor ?



  • Hello
    i need to run phonon player in arm based processor,
    is it possible to run phonon player in arm based processor ?


  • Lifetime Qt Champion

    Hi,

    That's a bit vague of a question. What distribution will you be using ? What problems are you getting ?



  • @SGaist
    Hi
    i am using ubuntu 12.04

    Below steps are followed...

    ./configure -prefix /usr/local/Qt_arm -embedded arm -little-endian -fast -DQT_QWS_CLIENTBLIT -depths 16,24,32 -xplatform qws/linux-arm-mygnueabi-g++ -arch arm -no-xinerama -glib -phonon -no-nis -no-opengl -no-cups -no-xcursor -no-xfixes -no-xrandr -no-xrender -no-sm -no-xinerama -no-xshape -no-separate-debug-info -nomake examples -nomake demos -confirm-license -phonon-backend

    ERROR is :

    To fix this include 'common/gcc-base-.conf and 'common/g++-.conf' instead
    Glib support cannot be enabled due to functionality tests!
    Turn on verbose messaging (-v) to ./configure to see the final report.
    If you believe this message is in error you may use the continue

    Please help me to solve this issue..


  • Moderators

    I think @SGaist asked about Linux distribution you're going to use on your ARM device.

    The error you get is: you do not have GLib libs/headers for your ARM device.



  • @jsulm yes i am using arm-none-linux-gnueabi-


  • Lifetime Qt Champion

    That's not a distribution, that's the tool chain. The question is: what flavor of Linux will you be running on your target ? And also what is your target ?



  • @SGaist @jsulm sorry for confussion, Embedded linux and dm385 target,


  • Lifetime Qt Champion

    Isn't DM385 the name of the processor ?
    Embedded Linux is rather a concept than a distribution name.

    Where are you getting your board from ? Is there any documentation available ?



  • @SGaist
    Hi..
    document: you will get here
    http://www.ti.com/product/DM385

    i will explain whole things, how i installed install embedded Qt
    1.tar -xvzf qt-everywhere-opensource-src-4.8.4.tar.gz
    * open the qt-everywhere-opensource-src-4.8.4 directory.
    * copying the directory mkspecs/qws/linux-arm-gnueabi-g++ and change the name like this mkspecs/qws/linux-arm-mygnueabi-g++

    1. Givin the below changes in mkspecs/qws/linux-arm-mygnueabi-g++/qmake.conf file.

    qmake configuration for building with arm-none-linux-gnueabi-g++

    include(../../common/g++.conf)
    include(../../common/linux.conf)
    include(../../common/qws.conf)
    TSLIB_INCDIR = /usr/local/tslib/include
    TSLIB_LIBDIR = /usr/local/tslib/lib

    modifications to g++.conf

    QMAKE_CC = arm-none-linux-gnueabi-gcc
    QMAKE_CXX = arm-none-linux-gnueabi-g++
    QMAKE_LINK = arm-none-linux-gnueabi-g++
    QMAKE_LINK_SHLIB = arm-none-linux-gnueabi-g++

    modifications to linux.conf

    QMAKE_AR = arm-none-linux-gnueabi-arcqs
    QMAKE_OBJCOPY = arm-none-linux-gnueabi-objcopy
    QMAKE_STRIP = arm-none-linux-gnueabi-strip
    QMAKE_INCDIR += $$TSLIB_INCDIR
    QMAKE_LIBDIR += $$TSLIB_LIBDIR
    QMAKE_LIBS += -lts
    load(qt_config)
    * Export the ARM tollchain installed path.
    $export PATH=/opt/arm_toolchain/bin:$PATH
    $ ./configure -prefix /usr/local/QtDM385 -embedded arm -little-endian -fast -DQT_QWS_CLIENTBLIT -depths 16,24,32 -xplatform qws/linux-arm-mygnueabi-g++ -arch arm -no-xinerama -no-phonon -no-nis -no-opengl -no-cups -no-xcursor -no-xfixes -no-xrandr -no-xrender -no-sm -no-xinerama -no-xshape -no-separate-debug-info -nomake examples -nomake demos -confirm-license

    • make
    • $sudo make install

    it works fine.,

    now i want to install with phonon so i tried like this

    ./configure -prefix /usr/local/QtDM385 -embedded arm -little-endian -fast -DQT_QWS_CLIENTBLIT -depths 16,24,32 -xplatform qws/linux-arm-mygnueabi-g++ -arch arm -no-xinerama -glib -phonon -no-nis -no-opengl -no-cups -no-xcursor -no-xfixes -no-xrandr -no-xrender -no-sm -no-xinerama -no-xshape -no-separate-debug-info -nomake examples -nomake demos -confirm-license -v

    then i am getting errors like this

    Determining system architecture... (Linux:3.11.0-24-generic:i686)
    32-bit Intel 80x86 (i386)
    'arm' is supported
    'i386' is supported
    System architecture: 'arm'
    Host architecture: 'i386'
    Precompiled-headers support enabled.
    Symbol visibility control enabled.

    This is the Qt for Embedded Linux Open Source Edition.

    You are licensed to use this software under the terms of
    the Lesser GNU General Public License (LGPL) versions 2.1.
    You are also licensed to use this software under the terms of
    the GNU General Public License (GPL) versions 3.

    You have already accepted the terms of the license.

    Creating qmake. Please wait...
    make: Nothing to be done for `first'.

    You have not explicitly asked to use pkg-config and are cross-compiling.
    pkg-config will not be used to automatically query cflag/lib parameters for
    dependencies

    floatmath auto-detection... ()
    Project WARNING: Your mkspec is including 'common/g++.conf', but the mkspecs have been refactored
    To fix this include 'common/gcc-base-.conf and 'common/g++-.conf' instead
    arm-none-linux-gnueabi-g++ -c -pipe -O2 -Wall -W -I../../../mkspecs/qws/linux-arm-mygnueabi-g++ -I. -I/usr/local/tslib/include -o floatmath.o floatmath.cpp
    floatmath.cpp:44: warning: unused parameter 'argc'
    floatmath.cpp:44: warning: unused parameter 'argv'
    arm-none-linux-gnueabi-g++ -Wl,-O1 -Wl,-rpath,/usr/local/Qt4.8.7_arm/lib -o floatmath floatmath.o -L/usr/local/tslib/lib -lts
    floatmath enabled.
    mmx auto-detection... ()
    Project WARNING: Your mkspec is including 'common/g++.conf', but the mkspecs have been refactored
    To fix this include 'common/gcc-base-.conf and 'common/g++-.conf' instead
    arm-none-linux-gnueabi-g++ -c -pipe -mmmx -O2 -Wall -W -I../../../mkspecs/qws/linux-arm-mygnueabi-g++ -I. -I/usr/local/tslib/include -o mmx.o mmx.cpp
    cc1plus: error: unrecognized command line option "-mmmx"
    make: *** [mmx.o] Error 1
    mmx disabled.
    3dnow auto-detection... ()
    Project WARNING: Your mkspec is including 'common/g++.conf', but the mkspecs have been refactored
    To fix this include 'common/gcc-base-.conf and 'common/g++-.conf' instead
    arm-none-linux-gnueabi-g++ -c -pipe -m3dnow -O2 -Wall -W -I../../../mkspecs/qws/linux-arm-mygnueabi-g++ -I. -I/usr/local/tslib/include -o 3dnow.o 3dnow.cpp
    cc1plus: error: unrecognized command line option "-m3dnow"
    make: *** [3dnow.o] Error 1
    3dnow disabled.
    .
    .
    .
    Glib disabled.
    Glib support cannot be enabled due to functionality tests!
    Turn on verbose messaging (-v) to ./configure to see the final report.
    If you believe this message is in error you may use the continue
    switch (-continue) to ./configure to continue.

    i dont know where i am going wrong.
    please suggesst me to install phonon ,


  • Lifetime Qt Champion

    Do you provide glib ?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.