Important: Please read the Qt Code of Conduct -

arm-linux-androideabi-gdb does not exist Android GCC 4.9

  • I tried to debug an Android application with Qt Creator v5.6.0, but could not configure the Android debugger:

    Error: Debugger "Android/Sdk/ndk-bundle/toolchains/arm-linux-androideabi-4.9/prebuilt/linux-x86_64/bin/arm-linux-androideabi-gdb" not found.

    [](Screenhost arm-linux-androideabi-gdb not found)

    The directory on my harddisk exists, but does not contain this executable.

    This is what I've done:

    1. Ubuntu 15.10 64-bit
    2. Tools installed:
      $ sudo apt-get install
      libstdc++6:i386 libgcc1:i386 zlib1g:i386 libncurses5:i386
    3. Qt Creator installed:
    4. android-sdk_r24.4.1-linux.tgz downloaded and extracted.
    5. All updates installed:
      $ tools/android update sdk --no-ui
    6. In Qt Creator > Tools > Options > Android:
      JDK location: /usr/lib/jvm/java-8-oracle
      Android SDK location: /home/<user>/Android/Sdk
      Android NDK location: /home/<user>/Android/Sdk/ndk-bundle
    7. In Qt Creator > Tools > Options > Build & Run > Kits:
      Exclamation mark: Android for armeabi-v7a (GCC 4.9, Qt 5.6.0)

    Can someone help me further?


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    AFAIK, you should currently use an older NDK which still provides arm-linux-androideabi-gdb

  • @SGaist
    I have same problem and even I downloaded latest ndk (android ndk r13b), still not getting this executed file within the folder.

    Do you have any idea about the same, how can I resolve it or any other alternative ?

  • Lifetime Qt Champion


    Check here and also you should take at look into the NDK to where you have gdb and tell Qt Creator where to find it.

  • I resolved it at my end.

    I found the folder path inside ndk folder was wrong, I provide right one and edit 'build.gradle' to its version and now its creating .apk file

  • Lifetime Qt Champion

    Good !

    Then please mark the thread as solved using the "Topic Tools" button so that other forum users may know a solution has been found :)

  • @SGaist
    I can not update, it can update by @Erriez

  • Lifetime Qt Champion

    My bad, I forgot that you weren't the original poster.

Log in to reply