QAssistant is empty



  • I have installed Qt with the new Online Installer (I used to use the Offline installer) on OSX El-Capitan.

    I notice that QAssistant is empty and doesn't reference the qch files, which are correctly placed in QTDIR/Docs. I think that's also why QtCreator doesn't autocomplete and doesn't have any doc.

    Is it a known bug? I have tried to uninstall and reinstall it, same. Thanks for your help


  • Lifetime Qt Champion

    Hi,

    Strange, what if you manually add the documentation ?



  • Manually adding a .qch adds it to the Assistant. But I would have to manually add all the .qch =S

    Apparently it's not known...



  • Ok now... I can see many docs (via F1) on QtCreator, but I don't have some autocomplete. For instance, QUuid::createUuid(), .toString isn't autocompleted but is working (and headers are present).

    Any idea?


  • Lifetime Qt Champion

    Which version did you install ?



  • 5.6 via online installer. I've only checked the minimum, but there is no checkbox about docs (anyway, they are installed).


  • Lifetime Qt Champion

    That's strange. Clean install or update ?



  • @SGaist Clean install. I mean, I firstly remove all components, then install normally



  • Finally, I have fresh installed it with Offline Installer, and it's working as expected. It seems isolated, so maybe nothing.

    Thank you for having tried ;)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.