Android Marshmallow and Qt Binaries



  • Hello,

    First of all, sorry for my bad English.

    I have an Android device with version 6.0.1 (Marshmallow) and Qt 5.6.0 installed via the Qt maintenance tool.

    I met a rather special problem is the following:

    I compile my application with the Android NDK r10e.
    The application works fine on Android 5.1.1
    However on Android 6.0.1 impossible to make it work I have constantly crashes.

    I also tried with the Android NDK r11c, but the support of the NDK r11c in Qt Creator 3.6.1 is limited.

    And it is impossible to debug the application, however when I run the application on Android 6.0.1, I have some kind of warning: w / linker on libQtGui.so, libQtNetwork.so ...

    Are there any way to make Qt 5.6.0 fully compatible with Android 6.0.1.

    If not do you have an idea of the binary version of Qt will be compatible with Android 6.

    Thank you in advance.

    Cordially.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    I'd recommend posting this on Qt's Android-development mailing list. You'll find there Qt's Android port developers/maintainers. This forum is more user oriented.

    You should also check the mailing list archive for posts about that matter.



  • Thank you for your response.

    I have subscribed to the mailing list and sent the question, I will update this topic when I have the response for the others devs they have the same troubles.

    Cordially.



  • I don't have any problems running my Qt5.6 application on Android 6. Did you try a very easy sample if it has the same problems? If yes, then you could post your APK and I will try it on my phone.

    If it works with a "Hello world" application, try to identify, what exactly causes the crashes.



  • I found the solution with the help of ekke and Max (on the android-development mailing-list), I forgot openssl for Android and I made a mistake with QSharedPointer

    Thank you for your help.


  • Qt Champions 2016

    great to hear that it works.
    for all not following the mailing lists, here's HowTo add OpenSSL if running into errors from Android 6: http://doc.qt.io/qt-5/opensslsupport.html



  • Hi @ekkescorner
    Are there any source example to solve in Windows OS this problem ? We are using Arcgis Runtime SDK for Qt 10.2.6 and Qt 5.4.2 (MSVC 2013, 32 bit) Qt Creator QT\QML side. And we are develop and deploy Adroid app with **Android Armeobi-v7a (GCC4.9 , QT 5.4.2) ** kid on Windows Operating System. So this is important problem with us .How can I solve this problem in Windows, your example is in Linux in below message ?

    Best Regards


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.