Qt5 application not reacting to click through VNC

  • Hi guys,
    I'm new to Qt5 and actually i'm working on Qt5 application on a custom board (SoC imx6, Linux 4.1.x ,Buildroot 2015.08.
    I found a first solution with x11vnc (whose the package is available in Buildroot ), technically it uses
    some of the libraries provided by X BUT i haven't enabled the Xorg server in Buildroot .
    I've successfully got my remote application through a VNC Client

    • On the target:

    I launch the Qt5 application with the following options
    ./myQt5app -platform linuxfb -geometry 500x500 -plugin evdevmouse &

    I start the x11vnc server like this
    x11vnc -noipv6 -rawfb /dev/fb0 -clip 500x500+0+0 -dk -dp

    • On my PC (Windows)

    I ran tightvncclient as you already know.

    My Problem is that my application doesn't react to inputs neither from my mouse nor from my keyboard.

    Is there anybody who arrived to make the inputs work ?

    PS: With -dk and -dp i see that the inputs are well received by the server , BUT , it seems that the the server doesn't redirect inputs to the application or something like that :(

  • Hello,
    I have got same problems with raspberry pi. I can get visual but not mouse or keyboard events.
    I digged http://www.karlrunge.com/x11vnc/x11vnc_opts.html and tried to
    -pipeinput direct_abs=/dev/input/event2 to send events to my device but didn't succeed.

    any more clue?

  • I think i've made some progress, but the events from the mouse are not always managed.

    1. I have added the uinput module to the Linux kernel (make menuconfig)
    2. I have created a node as explained in the documentation of x11vnc ( http://www.karlrunge.com/x11vnc/x11vnc_opts.html#opt-pipeinput )
    3. I start the vncserver firstly with the following command:
      x11vnc -noipv6 -clip 500x500+0+0 -rawfb /dev/fb0 -pipeinput UINPUT:direct_abs= /dev/input/uinput (-dp -dk) &
    4. After that i've checked the /dev/input and noticed that a char node called event0 was created (/dev/input/event0)
    5. Then i can start my Qt5 application like this:
      ./myApp -geometry 500x500 -platform linuxfb -plugin evdevmouse:/dev /input/event0

    Then i can move from one button to another using UP,DOWN,LEFT and RIGHT Key. I can push the buttons using the SPACE button ... that's cool my Application works correctly (^_^)/, but still no click :-( ... still looking...

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.