Development android on Mac



  • **When developing on mac I get the output in debug cant run deploy and test my project what could be the issue here someone please help me out **

    17:09:57: Running steps for project pinewoodapp...
    17:09:57: Starting: "/Users/Mike/Qt5.5.0/5.5/android_x86/bin/qmake" '/Users/Mike/Documents/Qt Projects/pinewoodapp/pinewoodapp.pro' -r -spec android-g++ CONFIG+=debug CONFIG+=declarative_debug CONFIG+=qml_debug
    17:10:09: The process "/Users/Mike/Qt5.5.0/5.5/android_x86/bin/qmake" exited normally.
    17:10:09: Starting: "/usr/bin/make"
    /Users/Mike/Library/Android/android-ndk-r10e/toolchains/x86-4.9/prebuilt/darwin-x86_64/bin/i686-linux-android-g++ -c -ffunction-sections -funwind-tables -O2 -fomit-frame-pointer -fstrict-aliasing -funswitch-loops -finline-limit=300 -DANDROID -Wa,--noexecstack -std=c++11 -g -g -Wall -Wno-psabi -W -D_REENTRANT -fPIC -DQT_QML_DEBUG -DQT_DECLARATIVE_DEBUG -DQT_QUICK_LIB -DQT_GUI_LIB -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I../pinewoodapp -I. -I../../../Qt5.5.0/5.5/android_x86/include -I../../../Qt5.5.0/5.5/android_x86/include/QtQuick -I../../../Qt5.5.0/5.5/android_x86/include/QtGui -I../../../Qt5.5.0/5.5/android_x86/include/QtQml -I../../../Qt5.5.0/5.5/android_x86/include/QtNetwork -I../../../Qt5.5.0/5.5/android_x86/include/QtCore -I. -I../../../Library/Android/android-ndk-r10e/sources/cxx-stl/gnu-libstdc++/4.9/include -I../../../Library/Android/android-ndk-r10e/sources/cxx-stl/gnu-libstdc++/4.9/libs/x86/include -I../../../Library/Android/android-ndk-r10e/platforms/android-9/arch-x86/usr/include -I../../../Qt5.5.0/5.5/android_x86/mkspecs/android-g++ -o main.o ../pinewoodapp/main.cpp
    /Users/Mike/Qt5.5.0/5.5/android_x86/bin/rcc -name qml ../pinewoodapp/qml.qrc -o qrc_qml.cpp
    /Users/Mike/Library/Android/android-ndk-r10e/toolchains/x86-4.9/prebuilt/darwin-x86_64/bin/i686-linux-android-g++ -c -ffunction-sections -funwind-tables -O2 -fomit-frame-pointer -fstrict-aliasing -funswitch-loops -finline-limit=300 -DANDROID -Wa,--noexecstack -std=c++11 -g -g -Wall -Wno-psabi -W -D_REENTRANT -fPIC -DQT_QML_DEBUG -DQT_DECLARATIVE_DEBUG -DQT_QUICK_LIB -DQT_GUI_LIB -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I../pinewoodapp -I. -I../../../Qt5.5.0/5.5/android_x86/include -I../../../Qt5.5.0/5.5/android_x86/include/QtQuick -I../../../Qt5.5.0/5.5/android_x86/include/QtGui -I../../../Qt5.5.0/5.5/android_x86/include/QtQml -I../../../Qt5.5.0/5.5/android_x86/include/QtNetwork -I../../../Qt5.5.0/5.5/android_x86/include/QtCore -I. -I../../../Library/Android/android-ndk-r10e/sources/cxx-stl/gnu-libstdc++/4.9/include -I../../../Library/Android/android-ndk-r10e/sources/cxx-stl/gnu-libstdc++/4.9/libs/x86/include -I../../../Library/Android/android-ndk-r10e/platforms/android-9/arch-x86/usr/include -I../../../Qt5.5.0/5.5/android_x86/mkspecs/android-g++ -o qrc_qml.o qrc_qml.cpp
    /Users/Mike/Library/Android/android-ndk-r10e/toolchains/x86-4.9/prebuilt/darwin-x86_64/bin/i686-linux-android-g++ --sysroot=/Users/Mike/Library/Android/android-ndk-r10e/platforms/android-9/arch-x86/ -Wl,-soname,libpinewoodapp.so -Wl,-rpath=/Users/Mike/Qt5.5.0/5.5/android_x86/lib -Wl,--no-undefined -Wl,-z,noexecstack -shared -o libpinewoodapp.so main.o qrc_qml.o -L/Users/Mike/Library/Android/android-ndk-r10e/sources/cxx-stl/gnu-libstdc++/4.9/libs/x86 -L/Users/Mike/Library/Android/android-ndk-r10e/platforms/android-9/arch-x86//usr/lib -L/Users/Mike/Qt5.5.0/5.5/android_x86/lib -lQt5Quick -L/opt/android/ndk/sources/cxx-stl/gnu-libstdc++/4.8/libs/x86 -L/opt/android/ndk/platforms/android-9/arch-x86//usr/lib -lQt5Gui -lQt5Qml -lQt5Network -lQt5Core -lGLESv2 -lgnustl_shared -llog -lz -lm -ldl -lc -lgcc
    17:10:52: The process "/usr/bin/make" exited normally.
    17:10:52: Starting: "/usr/bin/make" 'INSTALL_ROOT=/Users/Mike/Documents/Qt Projects/build-pinewoodapp-Android_for_x86_GCC_4_9_Qt_5_5_0-Debug/android-build' install
    /bin/sh: line 0: test: /Users/Mike/Documents/Qt: binary operator expected
    install -m 755 -p libpinewoodapp.so /Users/Mike/Documents/Qt Projects/build-pinewoodapp-Android_for_x86_GCC_4_9_Qt_5_5_0-Debug/android-build/libs/x86/libpinewoodapp.so
    usage: install [-bCcpSsv] [-B suffix] [-f flags] [-g group] [-m mode]
    [-o owner] file1 file2
    install [-bCcpSsv] [-B suffix] [-f flags] [-g group] [-m mode]
    [-o owner] file1 ... fileN directory
    install -d [-v] [-g group] [-m mode] [-o owner] directory ...
    make: [install_target] Error 64 (ignored)
    17:10:54: The process "/usr/bin/make" exited normally.
    17:10:54: Starting: "/Users/Mike/Qt5.5.0/5.5/android_x86/bin/androiddeployqt" --input '/Users/Mike/Documents/Qt Projects/build-pinewoodapp-Android_for_x86_GCC_4_9_Qt_5_5_0-Debug/android-libpinewoodapp.so-deployment-settings.json' --output '/Users/Mike/Documents/Qt Projects/build-pinewoodapp-Android_for_x86_GCC_4_9_Qt_5_5_0-Debug/android-build' --deployment bundled --android-platform android-23 --jdk /System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/Home --ant ant
    Application binary is not in output directory: /Users/Mike/Documents/Qt Projects/build-pinewoodapp-Android_for_x86_GCC_4_9_Qt_5_5_0-Debug/android-build//libs/x86/libpinewoodapp.so. Please run 'make install INSTALL_ROOT=/Users/Mike/Documents/Qt Projects/build-pinewoodapp-Android_for_x86_GCC_4_9_Qt_5_5_0-Debug/android-build/' first.
    Generating Android Package
    Input file: /Users/Mike/Documents/Qt Projects/build-pinewoodapp-Android_for_x86_GCC_4_9_Qt_5_5_0-Debug/android-libpinewoodapp.so-deployment-settings.json
    Output directory: /Users/Mike/Documents/Qt Projects/build-pinewoodapp-Android_for_x86_GCC_4_9_Qt_5_5_0-Debug/android-build/
    Application binary: /Users/Mike/Documents/Qt Projects/build-pinewoodapp-Android_for_x86_GCC_4_9_Qt_5_5_0-Debug/libpinewoodapp.so
    Android build platform: android-23
    Install to device: No
    17:10:58: The process "/Users/Mike/Qt5.5.0/5.5/android_x86/bin/androiddeployqt" exited with code 7.
    Error while building/deploying project pinewoodapp (kit: Android for x86 (GCC 4.9, Qt 5.5.0))
    When executing step "Build Android APK"
    17:10:58: Elapsed time: 01:02.


  • Lifetime Qt Champion

    Hi,

    Are you using gradle ?



  • Hello,
    Nope am not.



  • Sorted it out Installed Q.t 5.6 and specified Ant Location. Am now good to Go its working Thanks Anyway..


  • Lifetime Qt Champion

    Good !

    Then please mark the thread as solved using the "Topic Tool" button so that other forum users may know a solution has been found :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.