Apply patch...



  • Hi guys, I've the problem that when I try to deploy app's in my device I receive "ABI's incompatible".
    I've seen that for this problem exist this patch https://codereview.qt-project.org/#/c/80296/1
    I don't understand how I can apply it.
    Anyone can help me to apply path?
    Thanks.

    Stefano


  • Lifetime Qt Champion

    Hi,

    What version of Qt Creator are you trying to build ? That patch seems to be in since 2014



  • Hi SGaist and thanks for your reply.
    I use:
    Qt Creator 3.6.0
    Based on Qt 5.5.1 (GCC 4.9.1 20140922 (Red Hat 4.9.1-10), 64 bit)
    Built on Dec 15 2015 01:01:12
    From revision b52c2f91f5
    under Ubuntu linux 14.04 64bit.

    I've seen that this patch is released on 2014, but I've tried all solutions found to internet, but without solution :(

    Stefano



  • Now seems to work, but I don't understand why :(


  • Lifetime Qt Champion

    Do you have two different versions of Qt Creator installed ?



  • No, only one.



  • Now Qt Creator told me "ABI's Incompatible" with same app that today has worked fine.
    The PC configuration and app is the same
    I don't understand the problem :(


  • Lifetime Qt Champion

    What's your device ? Did you change anything on it ?



  • @SGaist
    No, I haven't changed nothing.
    But, perhaps I must explain what I did.
    Yesterday, looking to resolve this issue, I've removed Qt Creator, deleted configuration, android sdk and ndk
    Then I've reinstalled sdk/ndk and QtCreator.
    I was very happy when I saw that after this everything was fine.
    Obviously yesterday night I've power off my pc.
    Today, I've power on my pc and I've worked but I haven't installed, removed package or changed any configuration.
    Today, I needed to upload a new app in my tablet and surprise...
    "ABI's Incompatible".

    My tablet is Hanspree HSG1279 with Android 4.4.2.
    Now I've tried to upload app in virtual device but it isn't uploaded.

    These are compiler messages:

    23:37:26: Running steps for project TestOSMMobile...
    23:37:26: Configuration unchanged, skipping qmake step.
    23:37:26: Starting: "/usr/bin/make" 
    make: Nothing to be done for `first'.
    23:37:26: The process "/usr/bin/make" exited normally.
    23:37:26: Removing directory /home/stefano/Documenti/Programmi/Qt/build-TestOSMMobile-Android_for_armeabi_GCC_4_9_Qt_5_5_1-Debug/android-build
    23:37:26: Starting: "/usr/bin/make" INSTALL_ROOT=/home/stefano/Documenti/Programmi/Qt/build-TestOSMMobile-Android_for_armeabi_GCC_4_9_Qt_5_5_1-Debug/android-build install
    install -m 755 -p libTestOSMMobile.so /home/stefano/Documenti/Programmi/Qt/build-TestOSMMobile-Android_for_armeabi_GCC_4_9_Qt_5_5_1-Debug/android-build/libs/default/armeabi-v7a/libTestOSMMobile.so
    23:37:26: The process "/usr/bin/make" exited normally.
    23:37:26: Starting: "/opt/Qt/5.5/android_armv5/bin/androiddeployqt" --input /home/stefano/Documenti/Programmi/Qt/build-TestOSMMobile-Android_for_armeabi_GCC_4_9_Qt_5_5_1-Debug/android-libTestOSMMobile.so-deployment-settings.json --output /home/stefano/Documenti/Programmi/Qt/build-TestOSMMobile-Android_for_armeabi_GCC_4_9_Qt_5_5_1-Debug/android-build --deployment bundled --android-platform android-23 --jdk /usr/lib/jvm/java-7-openjdk-amd64 --ant /usr/bin/ant
    Warning: QML import could not be resolved in any of the import paths: QtQuick.Extras.Private
    Warning: QML import could not be resolved in any of the import paths: QtQuick.Extras.Private.CppUtils
    Warning: QML import could not be resolved in any of the import paths: QtQuick.Extras.Private.CppUtils
    Warning: QML import could not be resolved in any of the import paths: HelperWidgets
    Application binary is not in output directory: /home/stefano/Documenti/Programmi/Qt/build-TestOSMMobile-Android_for_armeabi_GCC_4_9_Qt_5_5_1-Debug/android-build//libs/armeabi/libTestOSMMobile.so. Please run 'make install INSTALL_ROOT=/home/stefano/Documenti/Programmi/Qt/build-TestOSMMobile-Android_for_armeabi_GCC_4_9_Qt_5_5_1-Debug/android-build/' first.
    Generating Android Package
      Input file: /home/stefano/Documenti/Programmi/Qt/build-TestOSMMobile-Android_for_armeabi_GCC_4_9_Qt_5_5_1-Debug/android-libTestOSMMobile.so-deployment-settings.json
      Output directory: /home/stefano/Documenti/Programmi/Qt/build-TestOSMMobile-Android_for_armeabi_GCC_4_9_Qt_5_5_1-Debug/android-build/
      Application binary: /home/stefano/Documenti/Programmi/Qt/build-TestOSMMobile-Android_for_armeabi_GCC_4_9_Qt_5_5_1-Debug/libTestOSMMobile.so
      Android build platform: android-23
      Install to device: No
    23:37:27: The process "/opt/Qt/5.5/android_armv5/bin/androiddeployqt" exited with code 7.
    Error while building/deploying project TestOSMMobile (kit: Android for armeabi (GCC 4.9, Qt 5.5.1))
    When executing step "Build Android APK"
    23:37:27: Elapsed time: 00:00.
    

    Thanks.

    Stefano


  • Lifetime Qt Champion

    Since you have 4.4.2 shouldn't you be targeting level 19 ?



  • Yes, you're right, but yesterday was also loaded the app without the level 19.
    In previous installation, I had also level 19, but message "ABIs Incompatible" there was same :(


  • Lifetime Qt Champion

    Previous installation ?



  • yes, friday looking to resolve this issue, I removed and reinstalled android sdk/ndk, qt creator and configuration.
    Right after installation everythingl works fine, but yesterday (after to have rebooted my PC) the problem (ABIs Incompatible) is back :(
    I had already wrote this in previous post, but prehaps for my bad english you didn't understand what I wanted to tell you.
    I'm sorry for my very bad english :(

    Stefano


  • Lifetime Qt Champion

    You just talked about Qt Creator not whether you re-installed Qt completely.



  • Yes, I told that I've completely deleted android-ndk, android-sdk, Qt and configuration and then I've reinstalled all packages.
    Yesterday in doubt I've installed also level 19 for Android 4.4.2.
    After this operation I uploaded app in my tablet without problem, then very happy I've power off my PC and I'm go to sleep.
    Today it is not working again.
    I don't understand what can change during machine reboot (Ubuntu 14.04 64bit).

    Stefano


  • Lifetime Qt Champion

    So, all in all: with a complete fresh install of Qt, Android NDK/SDK, everything is working, but with a reboot it's not ?

    Did you recheck Qt Creator's Android settings to see if anything is different ?



  • I've already checked it and configuration is the same.
    Perhaps are file permissions, but to be sure I've assigned 777 to all files and folders in android-sdk, ndk and Qt.
    But this test don't solve the problem.



  • Hi, I'm continuing to have the problem :(
    These are all informations that I can give to help me:

    This is the problem
    http://www.enterprice.it/error.png

    This is Qt configuration
    http://www.enterprice.it/qtconf.png
    http://www.enterprice.it/qtversion.png

    This is SDK configuration
    http://www.enterprice.it/sdk1.jpg
    http://www.enterprice.it/sdk2.jpg

    I've tried all I had in mind, but without success :(
    Have you some ideas?
    Thanks.

    Stefano


  • Lifetime Qt Champion

    What's that device that's not compatible ?



  • Hi SGaist,
    I've 3 devices:

    • Tablet Samsung SM-T535/Android 5.0.2 - it seems to work fine
    • Phone LG G3/Android 5.0 - ABIs Incompatible
    • Tablet Hannspree HSG1279/Android 4.4.2 - ABIs Incompatible

    is strange that:

    • Samsung Tablet always works fine
    • LG G3 Never works
    • Hanspree Tablet sometimes it work

    Debug USB is active in all devices

    Stefano


  • Lifetime Qt Champion

    Did you install all API levels down to 19 ?



  • Hi SGaist, yesterday I had some time and I've searched on google the solution with different keys.
    I've found solution.
    It was change some rule in udev.
    Now all work fine.
    Thanks for your attention and patience.

    Stefano


  • Lifetime Qt Champion

    What change did you had to do to the udev rules ?



  • I've created "51-android.rules" and added this line:
    SUBSYSTEM=="usb", ATTRS{idVendor}=="10d6", MODE="0666"
    where "10d6" is vendor id of my tablet.

    Stefano


  • Lifetime Qt Champion

    Ok, thanks for sharing.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.