How to enable EGLFS KMS



  • I was trying to use EGLFS KMS through command-line configuration -platform eglfs and setting QT_QPA_EGLFS_INTEGRATION=eglfs_kms. Unfortunately, it did not work. Then I found out that the EGLFS KMS is not enabled at my configuration:

    QPA backends:
    DirectFB ............. no
    EGLFS ................ yes
    EGLFS i.MX6....... . no
    EGLFS KMS .......... no
    EGLFS Mali ......... no
    EGLFS Raspberry Pi . no
    EGLFS X11 .......... no
    LinuxFB .............. yes
    XCB .................. no
    ...

    It is not cleared how to enable EGLFS KMS. Any help will be highly appreciated.

    Best regards,

    Eric


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    to enable kms from configure you can call configure -kms, you also need to have libdrm-dev installed.



  • Thank you very much!
    Yes, I was able to rebuild QT5 and enable EGLFS-KMS now.



  • @SGaist said in How to enable EGLFS KMS:

    Hi and welcome to devnet,
    to enable kms from configure you can call configure -kms, you also need to have libdrm-dev installed.

    Hi I need to do this too. But i didn't get where to call this command. Could you help? Thanks.

    Also, I don't see eglfs_kms option in configure summary. So I don't know what's missing here.

    QPA backends:
    DirectFB ............. no
    EGLFS ................ yes
    EGLFS i.MX6....... . no
    EGLFS GBM .......... no
    EGLFS Mali ......... no
    EGLFS Raspberry Pi . no
    EGLFS X11 .......... no
    LinuxFB .............. no
    XCB .................. no


  • Lifetime Qt Champion

    Hi,

    It's an option of the configure script.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.