Qt Creator 3.5.1 qmake errors with Qt 5.5.1



  • This is my first post on Qt Forums and I am not sure if this is the right place. Also, I am a IC design engineer and so software building is not quite my forte.
    I am trying to compile qt-creator 3.5.1 with Qt 5.5.1 on Ubuntu 14.04. I was able to compile and install Qt 5.5.1 successfully with the following switches on configure :
    -qt-xcb -nomake examples -nomake tests -skip qtwebchannel -no-opengl -skip qtwayland
    (note that most of these switches were added to eliminate compile errors)
    However, when I try to run qmake -r to build qt creator 3.5.1 with this version of Qt 5.5.1, I get the following error during qmake -r

    Reading <compile_dir>/src/libs/timeline/timeline.pro
    Project ERROR: Unknown module(s) in QT: quick

    Qt 5.5.1 does not seem to contain the module quick. But then again I am not sure if I am reading the Makefile properly. Any help with this is greatly appreciated.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Since software building is not your main strength, why not use Qt's online installer rather than build everything yourself ?

    AFAIR, you can still get the quick module through the installer for Qt 5.5



  • Thanks. I did try that with an older version of Qt and Qt creator but I ran into other issues that I did not document. With Qt though, I found compiling from scratch easier. I will go through the exercise with the latest version.


  • Lifetime Qt Champion

    Then you might need to build the qtquick module before Qt Creator. Nothing complicated: just run qmake/make/make install. But be sure to use the qmake you get with the Qt you just built.



  • SGaist,
    I did try your suggestion of installing from the online installer and everything installed fine with a few pre-installations required (details below) :

    It did require the installation of mesa-common-dev and libgl1-mesa-dev that were needed to prevent the following Qt build errors on my Ubuntu 14.04 machine.

    <QtHome>/5.5/gcc_64/include/QtGui/qopengl.h:122: error: GL/gl.h: No such file or directory
    include <GL/gl.h>

    Cannot link -lGL

    Thanks
    hwe1973


  • Lifetime Qt Champion

    That one's a classic (and a question that regularly comes back)



Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.