Incorrect Toolchain with Xcode



  • Hello I had two versions of Xcode installed (6.4 and 7.1) and was using code-select to choose between them. I ran into a few issues and decided to get rid of Xcode 6.4. Now whenever I try and build a project in Qt I get an Xcodebuild failed error. When I try and build in Xcode I get Command /Applications/Xcode6.4/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang failed with exit code 71. This clearly does not work because Xcode 6.4 is no longer there but I cannot find anyplace or technique to get change this in Qt. I have uninstalled and reinstalled Qt and looked at all the settings I can find.

    How can I point it to the correct version of Xcode? Thanks.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Did you regenerate the Xcode project after deleting Xcode 6.4 ?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.