Qt 5.x does not compatible with iOS 9 ?



  • I upgraded Xcode to version 7.0, and then Qt can not use iOS kit.
    Not all possible target environments can be supported due to missing compilers.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Just a wild guess but current Qt release should be compiled agains the iOS 8 SDK which is probably not shipped by default with Xcode 7. You should check if you can download the iOS 8 SDK and try again.

    Hope it helps



  • Thanks a lot !



  • Any more info on this? I pulled iOS8.4sdk from my time machine history and added it back into the xcode app, but still get the same error



  • I still can't solve this problem. If you have any solutions, please reply, thanks !



  • @JP_36 @YuanRuifeng
    you can try to rename or copy the folder

    iphone simulator
    /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator.sdk
    to
    /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator8.4.sdk

    iphone os
    /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS.sdk
    to
    /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS8.4.sdk

    it did a workaround for me



  • This is definitely not the best solution, but I was able to get everything working again by deleting XCode, rebooting, time machining Xcode 6.4 back, rebooting.

    I think you could get away with just Time Machining, so I don't think you need to delete XCode and reboot before time machining. Just sharing the round about steps I took.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.