I get the "no vali kit" error when I run Qt creator as a non-super user



  • Hi.

    First of all I should mention that I'm using Linux mint 17.1 on my laptop. When I want to create an empty project in Qt creator, I'll get an "No valid kit" error (I don't even know what a kit is). It directs me to options to create a kit. When I go to options I can see that a kit named "Desktop" exist. there is also a compiler set in compiler Tab. But what is missing is a Qt version. So I tried to add it manually but when I browse "/usr/bin", I can't find any "qmake". This is while I can locate "/usr/bin/qmake" using terminal.
    I tried to run Qt creator as super user and this time there was a Qt version set named "Qt 4.8.6" and I was able to create a project.
    I don't want to run Qt creator as super user each time I use it so can anyone help me with this issue?


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    How did you install Qt Creator on your machine ?

    A Kit is a Qt setup containing a Compiler + Qt version + Debugger + some other stuff if needed.



  • @SGaist Hi and thanks for your reply.
    I installed Qt using Linux mint software manager. I installed qt creator which was described (lightweight ide) and qt-sdk which was described (complete Qt sdk). I don't think I missed anything.


  • Lifetime Qt Champion

    Looks like a glitch in Mint then.
    Just to be sure, you installed everything from the software manager ?



  • Yes. It said "complete Qt SDK" so I realize it must contain everything.



  • Linux mint, being based on Ubuntu also shares the same packages (I use Kubuntu). QtCreator is a separate package and doesn't actually install any of the development packages needed as far as I know (it just recommends them). Do sudo apt install qtbase5-dev qt5-default qtdeclarative5-dev, you won't be able to see the kit right away, go to Tools -> Options -> Build & Run -> Qt Versions -> Add Kit add /usr/bin/qmake which should link to qmake qt5. A list of Qt5 dev packages and their respective modules.



Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.