Qt installation error: The tslib functionality test failed!



  • i have ubuntu 14 and install arm-linuc-gcc 4.4.3 in this path : /opt/FriendlyARM/toolschain/4.4.3/bin.
    i export the path and go step by step with this site:https://importgeek.wordpress.com/2012/04/09/compiling-qt-and-tslib-for-mini2440-and-run-a-demo-app/
    (exatly do the command line inuser not root ($) but for git comman need to sudo keyword to install and for some other like Qt configure and Qt untar i used sudo keyword)
    after i install tslib( with some warning) and change the /usr/local/tslib permission from root to owner user of pc and run configure the Qt i see this error:
    g++ -o "/opt/qt-everywhere-opensource-src-4.6.3/bin/qmake" project.o property.o main.o makefile.o unixmake2.o unixmake.o mingw_make.o option.o winmakefile.o projectgenerator.o meta.o makefiledeps.o metamakefile.o xmloutput.o pbuilder_pbx.o borland_bmake.o msvc_dsp.o msvc_vcproj.o msvc_nmake.o msvc_objectmodel.o symmake.o initprojectdeploy_symbian.o symmake_abld.o symmake_sbsv2.o registry.o epocroot.o qtextcodec.o qutfcodec.o qstring.o qtextstream.o qiodevice.o qmalloc.o qglobal.o qbytearray.o qbytearraymatcher.o qdatastream.o qbuffer.o qlist.o qfile.o qfsfileengine_unix.o qfsfileengine_iterator_unix.o qfsfileengine.o qfsfileengine_iterator.o qregexp.o qvector.o qbitarray.o qdir.o qdiriterator.o quuid.o qhash.o qfileinfo.o qdatetime.o qstringlist.o qabstractfileengine.o qtemporaryfile.o qmap.o qmetatype.o qsettings.o qlibraryinfo.o qvariant.o qvsnprintf.o qlocale.o qlinkedlist.o qurl.o qnumeric.o qcryptographichash.o qxmlstream.o qxmlutils.o
    The tslib functionality test failed!
    You might need to modify the include and library search paths by editing
    QMAKE_INCDIR and QMAKE_LIBDIR in
    /opt/qt-everywhere-opensource-src-4.6.3/mkspecs/qws/linux-arm-g++.

    in the comment of that site i see : "according to my knowledge this may occur due to two reasons…one is that you may miss typed or dropped some part of the qmake.conf while copying…..else it will be a permission issue". but i copy paste the qmake.conf(and correct the path of compiler to my path) and do the same as the site. but i have this error. some days a go i have the same error. but i solved that with chmod 777 -R /usr/local/tslib and make a program on mini 2440 and it run on my device( but the touch not work) i thought maybe my tslib is wrong and i remove them and install again. but now i have exactly thet error and not solve it.
    I AM SO CONFUSED.PLEASE HELP ME :(



  • Hi, I did manage it to compile qt with tslib

    In my qmake.conf before load(qt_config) I pasted the following_

    #defines for tslib
    QMAKE_INCDIR += ~/qt/tslib/include
    QMAKE_LIBDIR += ~/qt/tslib/lib

    This directory is my source dir of tslib.

    Maybee this is what you are missing. In the configure call I added this: -qt-mouse-tslib -plugin-mouse-tslib

    I hope this helps you.
    Ragards, Ben



  • hi and thanx for your reply.
    i change tslib and i used another site to guide : http://qtinstall.blogspot.in/
    this is my qmake.conf:

     # qmake configuration for building with arm-linux-g++
     #
    

    include(../../common/g++.conf)
    include(../../common/linux.conf)
    include(../../common/qws.conf)

    modifications to g++.conf

    QMAKE_CC = /opt/FriendlyARM/toolschain/4.4.3/bin/arm-linux-gcc -msoft-float -D__GCC_FLOAT_NOT_NEEDED -march=armv4t -mtune=arm920t -O0 -lts
    QMAKE_CXX = /opt/FriendlyARM/toolschain/4.4.3/bin/arm-linux-g++ -msoft-float -D__GCC_FLOAT_NOT_NEEDED -march=armv4t -mtune=arm920t -O0 -lts
    QMAKE_LINK = /opt/FriendlyARM/toolschain/4.4.3/bin/arm-linux-g++ -msoft-float -D__GCC_FLOAT_NOT_NEEDED -march=armv4t -mtune=arm920t -O0 -lts
    QMAKE_LINK_SHLIB =/opt/FriendlyARM/toolschain/4.4.3/bin/arm-linux-g++ -msoft-float -D__GCC_FLOAT_NOT_NEEDED -march=armv4t -mtune=arm920t -O0 -lts

    #modifications to linux.conf
    QMAKE_AR= /opt/FriendlyARM/toolschain/4.4.3/bin/arm-linux-ar cqs
    QMAKE_OBJCOPY = /opt/FriendlyARM/toolschain/4.4.3/bin/arm-linux-objcopy
    QMAKE_STRIP= /opt/FriendlyARM/toolschain/4.4.3/bin/arm-linux-strip
    QMAKE_RANLIB = /opt/FriendlyARM/toolschain/4.4.3/bin/arm-linux-ranlib

    QMAKE_INCDIR += ~/usr/local/Crosstslib/include/
    QMAKE_LIBDIR += ~/usr/local/Crosstslib/lib/

    QMAKE_CFLAGS_RELEASE += -march=armv4 -mtune=arm920t
    QMAKE_CFLAGS_DEBUG += -march=armv4t -mtune=arm920t
    QMAKE_CFLAGS_MT += -march=armv4t -mtune=arm920t
    QMAKE_CFLAGS_MT_DBG += -march=armv4t -mtune=arm920t
    QMAKE_CFLAGS_MT_DLL += -march=armv4t -mtune=arm920t
    QMAKE_CFLAGS_MT_DLLDBG += -march=armv4t -mtune=arm920t
    QMAKE_CFLAGS_SHLIB += -march=armv4t -mtune=arm920t
    QMAKE_CFLAGS_THREAD += -march=armv4t -mtune=arm920t
    QMAKE_CFLAGS_WARN_OFF += -march=armv4t -mtune=arm920t
    QMAKE_CFLAGS_WARN_ON += -march=armv4t -mtune=arm920t
    QMAKE_CXXFLAGS_DEBUG += -march=armv4t -mtune=arm920t
    QMAKE_CXXFLAGS_MT += -march=armv4t -mtune=arm920t
    QMAKE_CXXFLAGS_MT_DBG += -march=armv4t -mtune=arm920t
    QMAKE_CXXFLAGS_MT_DLL += -march=armv4t -mtune=arm920t
    QMAKE_CXXFLAGS_MT_DLLDBG += -march=armv4t -mtune=arm920t
    QMAKE_CXXFLAGS_RELEASE += -march=armv4t -mtune=arm920t
    QMAKE_CXXFLAGS_SHLIB += -march=armv4t -mtune=arm920t
    QMAKE_CXXFLAGS_THREAD += -march=armv4t -mtune=arm920t
    QMAKE_CXXFLAGS_WARN_OFF += -march=armv4t -mtune=arm920t
    QMAKE_CXXFLAGS_WARN_ON += -march=armv4t -mtune=arm920t
    load(qt_config)

    and this is my config command :


    ./configure -embedded arm -xplatform qws/linux-arm-g++ -prefix /usr/local/Qt -qt-mouse-tslib -little-endian -no-webkit -no-qt3support -no-cups -no-largefile -optimized-qmake -no-openssl -nomake tools -qt-sql-sqlite -no-3dnow -system-zlib -qt-gif -qt-libtiff -qt-libpng -qt-libmng -qt-libjpeg -no-opengl -gtkstyle -no-openvg -no-xshape -no-xsync -no-xrandr -qt-freetype -qt-gfx-linuxfb -qt-kbd-tty -qt-kbd-linuxinput -qt-mouse-tslib -qt-mouse-linuxinput -qt-mouse-tslib -plugin-mouse-tslib


    Which edition of Qt do you want to use ?

    Type 'c' if you want to use the Commercial Edition.
    Type 'o' if you want to use the Open Source Edition.

    o

    You have not explicitly asked to use pkg-config and are cross-compiling.
    pkg-config will not be used to automatically query cflag/lib parameters for
    dependencies

    This is the Qt for Embedded Linux Open Source Edition.

    You are licensed to use this software under the terms of
    the Lesser GNU General Public License (LGPL) versions 2.1.
    You are also licensed to use this software under the terms of
    the GNU General Public License (GPL) versions 3.

    Type '3' to view the GNU General Public License version 3.
    Type 'L' to view the Lesser GNU General Public License version 2.1.
    Type 'yes' to accept this license offer.
    Type 'no' to decline this license offer.

    Do you accept the terms of either license? yes

    Creating qmake. Please wait...
    arm-none-linux-gnueabi-g++ -c -o project.o -pipe -DQMAKE_OPENSOURCE_EDITION -O0 -I. -Igenerators -Igenerators/unix -Igenerators/win32 -Igenerators/mac -Igenerators/symbian -I/home/fara/Downloads/qt-everywhere-opensource-src-4.6.3/include -I/home
    .
    .
    .
    .

    /home/fara/Downloads/qt-everywhere-opensource-src-4.6.3/bin/qmake: 1: /home/fara/Downloads/qt-everywhere-opensource-src-4.6.3/bin/qmake: Syntax error: word unexpected (expecting ")")
    The tslib functionality test failed!
    You might need to modify the include and library search paths by editing
    QMAKE_INCDIR and QMAKE_LIBDIR in
    /home/fara/Downloads/qt-everywhere-opensource-src-4.6.3/mkspecs/qws/linux-arm-g++.

    it doesn't work. help me plzzzzzzzzzz :(



  • Hi, try this:

    OK you compiled libts

    the website you mentioned says
    ..
    QMAKE_INCDIR += /usr/local/Crosstslib/include/
    QMAKE_LIBDIR += /usr/local/Crosstslib/lib/
    ..
    you should do a sudo make + sudo make install for the libts.
    After that the directory /usr/local/Crosstslib/ should contain the binary and a header file. Use this path in your qmake.conf.

    Do not link the libts in QMAKE_ Flags in qmake.conf
    (It was not needed for me as well) :
    QMAKE_CC = /opt/FriendlyARM/toolschain/4.4.3/bin/arm-linux-gcc -msoft-float -D__GCC_FLOAT_NOT_NEEDED -march=armv4t -mtune=arm920t -O0
    QMAKE_CXX = /opt/FriendlyARM/toolschain/4.4.3/bin/arm-linux-g++ -msoft-float -D__GCC_FLOAT_NOT_NEEDED -march=armv4t -mtune=arm920t -O0
    QMAKE_LINK = /opt/FriendlyARM/toolschain/4.4.3/bin/arm-linux-g++ -msoft-float -D__GCC_FLOAT_NOT_NEEDED -march=armv4t -mtune=arm920t -O0
    QMAKE_LINK_SHLIB =/opt/FriendlyARM/toolschain/4.4.3/bin/arm-linux-g++ -msoft-float -D__GCC_FLOAT_NOT_NEEDED -march=armv4t -mtune=arm920t -O0
    ...
    ...
    QMAKE_CXXFLAGS_WARN_ON += -march=armv4t -mtune=arm920t

    #defines for tslib
    QMAKE_INCDIR += /usr/local/Crosstslib/include
    QMAKE_LIBDIR += /usr/local/Crosstslib/lib

    load(qt_config)
    /------------------ end of qmake.conf

    you can specify this to configure command to omit the license question:
    ./configure -opensource -confirm-license ....

    hopefully this helps.
    Regards, Ben



  • hi again.
    i remove link as u say and i log in in terminal as root (#) and use this:
    #defines for tslib
    QMAKE_INCDIR += /usr/local/Crosstslib/include
    QMAKE_LIBDIR += /usr/local/Crosstslib/lib
    but again i see the error tslib failed :(
    i do exactly like this : http://qtinstall.blogspot.in/ . but i have error. i look for another sites but i each way i used i see this error.
    .
    .
    .
    .
    /opt/qt-everywhere-opensource-src-4.6.3/bin/qmake: 1: /opt/qt-everywhere-opensource-src-4.6.3/bin/qmake: Syntax error: word unexpected (expecting ")")
    The tslib functionality test failed!
    You might need to modify the include and library search paths by editing
    QMAKE_INCDIR and QMAKE_LIBDIR in
    /opt/qt-everywhere-opensource-src-4.6.3/mkspecs/qws/linux-arm-g++.

    what am i doing know? am i miss lib or another?



  • I find the reason:
    in these way this error occurred :
    1- the permission of file : the output of tslib should has full permission :chmod -R 777 /.../.../tslib
    2- the address of tslib is wrong. if you write wrong address this error display
    3-if you install tslib successfully , and then remove it and install it gain this error show you. i change my linux and install another one but should clean all the tslib file and details.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.