QtLocation geoservice plugin on iOS



  • I wrote a proper plugin (geoservice) for QtLocation. The plugin is correctly loaded on Linux and Android. But on iOS (and even Windows) im not able to integrate the plugin into the application. Has anybody an idea what I'm doing wrong?

    My project file:
    TEMPLATE = lib
    QT += location-private positioning-private network xml
    CONFIG += qt plugin
    CONFIG += lib_bundle create_prl

    TARGET = geoservices_wms
    DESTDIR = $$[QT_INSTALL_PLUGINS]/geoservices

    PLUGIN_TYPE = geoservices
    PLUGIN_CLASS_NAME = WMSProvider


  • Lifetime Qt Champion

    Hi,

    You can start your application with QT_DEBUG_PLUGINS set to 1 in the environment variables to see what is happening.



  • @SGaist
    Hi, how can i enable QT_DEBUG_PLUGINS for iOS? I have no problem on Linux, but I cannot find where set it for iOS.

    I think the environment doesn't find the library. In xcode, I can find all the dependencies to the other geoservices. My plugin is missing , in the xcode dependencies. The library is located in correctly in the plugin/geoservices folder. So I suppose, I missed something in the configuration....

    Thx



  • Hi,
    Do you succeed to resolve this ?
    Indeed, I try to create a new GeoService plugin with the same issues...

    Thanks.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.