Important: Please read the Qt Code of Conduct -

[Solved] Qt 5.5 final release unable to deploy to iOS

  • Hi,
    i can not deploy my app anymore to iOS. Always getting this error:

    Starting remote process.
    TransferAppSession(26d492b5d61eaee2ac5120066cd5e3ba7d094c6f, /development/qtcreator-workspace/build-AVIATOReLogbook-iphoneos_clang_Qt_5_5_0_for_iOS-Debug/AVIATOReLogbook-App/Debug-iphoneos/ to get app Path on device for bundle /development/qtcreator-workspace/build-AVIATOReLogbook-iphoneos_clang_Qt_5_5_0_for_iOS-Debug/AVIATOReLogbook-App/Debug-iphoneos/ with appId: aero.aviatorsoft.AVIATOReLogbook-App
    TransferAppSession(26d492b5d61eaee2ac5120066cd5e3ba7d094c6f, /development/qtcreator-workspace/build-AVIATOReLogbook-iphoneos_clang_Qt_5_5_0_for_iOS-Debug/AVIATOReLogbook-App/Debug-iphoneos/ reply: ENo such file or directory () (454e6f20737563682066696c65206f72206469726563746f7279202829) vs OK (4f4b)
    Run ended.

    any idea whats going on here?
    I completely cleaned and rebuilt the app, but without success. :-(


  • i have problem with use iphoneos libNetwork.a, it always show me the error message about ' undefine symbol architecture arm64'
    did you get the same problem on xcode?

  • @love8879201 No, i can compile and link successfully. Problem occurs after trying to run (deploy) the package on the real device.

  • Lifetime Qt Champion


    Do you have the same problem with a default created project ? e.g. a new Qt Quick application

  • @SGaist
    Yes, also with the examples...
    i completly removed Qt and reinstalled it.
    Rebooted my devices (iPhone + iPad Mini3)...
    Same error on both devices... Reproducable....
    Very strange...

  • Lifetime Qt Champion

    What version of Xcode and iOS are you running ?

  • @SGaist
    Lastest Xcode 6.4 and iOS 8.4 on lastest OSX Yosemite...


  • I completly reinstalled Mac OS X, then applied all updates and installed fresh XCode 6.4 and Qt 5.5.
    Now it works....


Log in to reply