Important: Please read the Qt Code of Conduct -

[Solved] How to configure settings in order to compile FrameBuffer QT5?

  • Hi,
    English is not my mother tongue and I’m still learning the language. Hope you can understand what I mean. Thanks in advance.
    I’m using QT 5 on LinuxKernle, BusyBox compiled by myself which is X86. I’m going to use Framebuffer instead of X11 to display images. I’m stuck here and don’t know how to set it through Configure and compile FrameBuffer QT5.

  • After running the compiled program prompts:

    This application failed to start because it could not find or load the Qt platform plugin "linuxfb".
    Available platform plugins are: linuxfb, minimal, offscreen.
    Reinstalling the application may fix this problem.

    configure -verbose -confirm-license -release -no-xcb -no-pch -no-icu -no-c++11 -no-cups -no-gtkstyle -make libs -opensource -skip qtactiveqt -skip qtandroidextras -skip qtconnectivity -skip qtenginio -skip qtimageformats -skip qtlocation -skip qtmacextras -skip qtsensors -skip qtserialport -skip qttranslations -skip qttools -skip qtwebkit-examples -skip qtwinextras -skip qtx11extras -xplatform linux-g++ -qpa eglfs -qpa linuxfb -evdev -prefix /Qt5

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Do you provide all dependencies on your target ? Run ldd on it to see what misses to load the linuxfb plugin

  • @SGaist Thank you for your help :)

    Run ldd Results:
    ldd ./untitled => (0xb76fc000) => /Qt5/lib/ (0xb70cc000) => /Qt5/lib/ (0xb6b08000) => /usr/lib/i386-linux-gnu/ (0xb6a06000) => /lib/i386-linux-gnu/ (0xb69e9000) => /lib/i386-linux-gnu/ (0xb683b000) => /Qt5/lib/ (0xb6396000) => /lib/i386-linux-gnu/ (0xb637a000) => /lib/i386-linux-gnu/ (0xb6333000) => /lib/i386-linux-gnu/ (0xb6319000) => /lib/i386-linux-gnu/ (0xb6314000) => /lib/i386-linux-gnu/ (0xb630b000)
    /lib/ (0xb76fd000) => /lib/i386-linux-gnu/ (0xb62e3000)

    **untitled **:I compiled a demo program

    And to determine the following settings are correct
    export QT_QPA_PLATFORM_PLUGIN_PATH=/plugins
    export QT_QPA_PLATFORM=linuxfb:tty=/dev/fb0

    Run untitled or suggested above error

  • @SGaist
    I compiled Qt library, ldd results.
    root@linuxdevelopos:/Qt5/lib# ldd ./ => (0xb77bc000) => /lib/i386-linux-gnu/ (0xb71c0000) => /lib/i386-linux-gnu/ (0xb71a6000) => /lib/i386-linux-gnu/ (0xb71a0000) => /lib/i386-linux-gnu/ (0xb7197000) => /usr/lib/i386-linux-gnu/ (0xb70af000) => /lib/i386-linux-gnu/ (0xb7069000) => /lib/i386-linux-gnu/ (0xb704c000) => /lib/i386-linux-gnu/ (0xb6e9d000)
    /lib/ (0xb77bd000)
    root@linuxdevelopos:/Qt5/lib# ldd ./ => (0xb76f7000) => /Qt5/lib/ (0xb6c8b000) => /lib/i386-linux-gnu/ (0xb6c56000) => /lib/i386-linux-gnu/ (0xb6c2d000) => /lib/i386-linux-gnu/ (0xb6c13000) => /usr/lib/i386-linux-gnu/ (0xb6b2b000) => /lib/i386-linux-gnu/ (0xb6ae5000) => /lib/i386-linux-gnu/ (0xb6ac8000) => /lib/i386-linux-gnu/ (0xb6919000) => /lib/i386-linux-gnu/ (0xb6914000) => /lib/i386-linux-gnu/ (0xb690b000)
    /lib/ (0xb76f8000)
    root@linuxdevelopos:/Qt5/lib# ldd ./ => (0xb7725000) => /Qt5/lib/ (0xb6c50000) => /Qt5/lib/ (0xb668c000) => /lib/i386-linux-gnu/ (0xb6656000) => /usr/lib/i386-linux-gnu/ (0xb656e000) => /lib/i386-linux-gnu/ (0xb6528000) => /lib/i386-linux-gnu/ (0xb650b000) => /lib/i386-linux-gnu/ (0xb635d000) => /lib/i386-linux-gnu/ (0xb6334000) => /lib/i386-linux-gnu/ (0xb631a000) => /lib/i386-linux-gnu/ (0xb6315000) => /lib/i386-linux-gnu/ (0xb630c000)
    /lib/ (0xb7726000)

    It does not contain x11

  • Lifetime Qt Champion

    Run ldd on the plugin itself in plugins/platform/

  • @SGaist Thank you very much :)
    the so file was not loaded which is required by ""
    It works now.

  • Lifetime Qt Champion

    Great ! Which library was missing ?

    Since it's working now, please update the thread title prepending [solved] so other forum users may know a solution has been found :)

    Also, don't forget to up-vote answers that helped you (in any thread you are reading), it will help others to find them more easily.

  • @SGaist

  • Lifetime Qt Champion

    All these libraries can't be missing

Log in to reply