Qt5.5 QML Video Gstremer1.0



  • Hello,

    I have succefully cross compiled qt 5.5 to RPi and I can run the examples however it can't play video:

    QML debugging is enabled. Only use this in a safe environment.
    Unable to query physical screen size, defaulting to 100 dpi.
    To override, set QT_QPA_EGLFS_PHYSICAL_WIDTH and QT_QPA_EGLFS_PHYSICAL_HEIGHT (in millimeters).
    qml: file:///home/pi/movies/big_buck_bunny_480p_h264.mov
    No m_videoSink available!
    qrc:///qml/qmlvideo/Scene.qml:42: TypeError: Cannot read property of null
    Application finished with exit code 0.
    

    During configure it show gstreamer1.0 enable. I can use gst-launch to play video on RPi. Before I had setup gstreamer on rpi, configure did show gstreamer disable and when I tried to run qml video example it said:
    defaultServiceProvider::requestService(): no service found for - "org.qt-project.qt.mediaplayer"

    So I think now it is using gstreamer1.0 but there is something else failing :s



  • I have exactly the same issue. I checked qtmultimedia code and added
    m_videoSink = gst_element_factory_make("eglglessink", NULL);
    Now m_videoSink gets created but there's still no video playing. Does qtmultimedia support gstreamer1.0 in EGLFS applications?



  • I compiled gstreamer version 1.4.5 (previously was 1.2.0) and still have this issue. Can someone confirm whether or not gstreamer1.0 is really supported and tested in Qt 5.5?



  • I have the same issue. Anyone got the solution ?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.