Cant run app for Android



  • Hi, I have been working with Qt Desktop for a year now, and I needed to set up the environment for Android. I have followed carefully the steps in Qt documentations, downloaded Android SDK, NDK, Ant and JDK 7. I included all the paths and created a kit for Android. I installed the latest Android APIs and System Images from SDK and also created a AVD Nexus running Android 5.1.
    I created a project (when i create a Widget project, in the supported platforms at the right, Android is not shown, as in tutorial I have seen) and build and run it on Desktop - eveything Ok. When I try to run it on Android, a pop up shows, wanting the path of the executable, saying it can not find it. I dont know what to include here, cause in all the tutorials I have seen the AVD should start automatically. (it is on, in the moment I try to run from Qt). I don't what other settings to check, been seven hours now, trying to figure out the problem.
    I think the problem is in the Kit or in the Debugger, or in the Qt Version that can not detect the Android Kits or AVDs. Or it is just a silly thing that just need a path for the executable when running. These are all my system setting, please let me know if you need other info:

    Qt Creator 3.3.2 (opensource)
    Based on Qt 5.4.1 (MSVC 2010, 32 bit)

    Android Kit:
    Name: Android
    File System Name: empty
    Device Type: Android Device
    Device: Run on Android(default for Android)
    Sysroot: empty
    Compiler: MinGw 4.9.1 32bit
    Environment: No Changes to apply
    Debugger: Android Debugger (I also tried to leave this Auto Detect, it was the same)
    Android GDB server: Auto-Detect (I also tried including: C:\Qt_for_Android\android-ndk-r10e\prebuilt\android-arm\gdbserver, it was the same)
    Qt Version: Qt 5.4.1 MinGW 32bit
    Qt mkspec: empty

    Qt Versions:
    Auto-Detected: QtQt %{Qt:Version} MinGW 32bit
    no Manual

    Compilers:
    MinGW 4.9.1 32 bit
    and several others for Android GCC (arm-4.8, mips, x86), but when I try to include them into the Android Kit, the Kit is not Available, I can choose only MinGW, which seems the most probable problem to me.

    Debuggers"
    Auto-Detect:
    GNU gdb 7.8 for MinGW
    CDB at ...
    Manual"
    Android with path : C:\Qt_for_Android\android-ndk-r10e\toolchains\arm-linux-androideabi-4.9\prebuilt\windows\bin\arm-linux-androideabi-gdb.exe

    I really dont know what the problem is, and I need to start asap, I have to finish the app in less then a week. Please, just any help would do :)

    TIA


  • Lifetime Qt Champion

    Hi,

    It might a silly question but did you install Qt for Android package ?



  • This post is deleted!

Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.