[SOLVED]Could this be a bug on QVideoWidget.



  • Using the video player example from Qt one can load a video and play it normally. Pressing fullscreen makes the QVideoWidget go fullscreen as expected.
    Now if you press Esc in order to exit fullscreen you might notice that things don't go as expected, the video is frozen but sound continues playing normally.
    If you try to press fullscreen again what happens is that the QVideoWidget will get displayed in its own window instead of going fullscreen (see images for reference).

    Why do you think this is happening?

    image1
    image2


  • Lifetime Qt Champion

    Hi,

    Sounds indeed like there's something fishy going on. You should check the bug report system to see if it's something known and if not please consider opening a new report providing a minimal compilable example that shows the behavior.



  • Hi SGaist,
    Seems like someone noticed it first, there is this report over here that contains a number of issues with the widget.

    The author should have probably not stacked all those issues in one report so it is closed, do you think I should open a new one?

    I do confirm the issue remains on Mac.


  • Lifetime Qt Champion

    The original author was asked to split the report so, if you don't' find anything then go on, create your new report with as much details and minimal compilable example


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.