[SOLVED] Some of the required modules (!winrt) are not available



  • Hi everyone,

    I want to build Qt for WinRT.
    So, I cloned the Qt sources and changed the git branch to 5.4.1
    And then used this command[1] to configure Qt for WinRT.
    Then used jom to build it.
    And after some time I got this error.
    Any Idea?

    cd qtwinextras\ && ( if not exist Makefile E:\windows\QtWinRTBuild\qtbase\bin\qmake E:\windows\qt5\qtwinextras\qtwinextras.pro -o Makefile ) && C:\bin\jom.exe -f Makefile "Some of the required modules (!winrt) are not available." "Skipped."

    [1] ..\qtFullSourceCode\configure.bat -xplatform winrt-x64-msvc2013 -developer-build -release -opensource -confirm-license -nomake tests

    Thanks
    Ashish Bansal


  • Lifetime Qt Champion

    Hi,

    This is not an error, it just tells you that the QtWinExtras module won't be build for winrt



  • @SGaist said:

    Hi,

    This is not an error, it just tells you that the QtWinExtras module won't be build for winrt

    Oh Okay, thanks SGaist.
    There should be winrtrunner.exe and some others which helps in deploying application to WinRT, inside buildDirectory/bin but there are no such files.

    Haven't I given correct built commands for building it for WinRT ?


  • Lifetime Qt Champion

    Looks like it, check the qttools module to see if it as been built, if not you can to it by hand



  • @SGaist Okay, I built them manually. Thanks a lot :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.