Issue with adding forum posts


  • Moderators

    The adding of posts seems to be not really stable. Just faced missing syncronization between left (typing) and right (preview) window.
    Overall I would not be bothered. However, also the submission of the post itself was not possible anymore.
    After 2-3 minutes I have updated the screen and lost the post itself. Luckily it was receovered starting a new topic. Only the headline had to be recreated.
    Problem occured with Chrome on Windows 7 64 bit.


  • administrators

    @koahnig this is a new problem.
    So the text was there when you tried to post again, which means that it was in the system, but not posted.

    Were there any other symptoms?
    Did you have the window open for long?

    I'll try to find out what the reason could be.


  • Moderators

    I had a similar issue a couple of times now. In my case it's usually a short reply with a code example. At some point the preview stops updating and after that hitting "Submit" has no effect (i.e. nothing happens on click, no reload, editor doesn't close and the post doesn't show up).

    I had two different reactions after reloading such page. Either it was still in editing mode and "Submit" button still didn't work or there was no editor opened and hitting "Reply" again opened the editor with previous text intact and "Submit" now working.

    Usually a couple of refreshes or going back to topic list and back to post fixes this. Up to now I though it might be my flunky network but if it's not only me...


  • administrators

    @Chris-Kawa
    If this is happening more widely we need to investigate it more.
    Doesn't sound like a random incident.

    Could be something in socket communications and the way they are handled.



  • I just had the very same issue as well. I'm using Firefox 36.0.1 and had several tabs open on the Qt Forum. Closing all the tabs, logging out and in again fixed the problem for me. However I don't now if just closing tabs or just logging out and in again would have fixed it as well.


  • administrators

    Question to all, have you had the tabs open for long?

    (I'm trying to figure if it's how we handle websocket connections)



  • @tekojo Mine were open for quite some time. I think I had them open for at least a day.


  • Moderators

    @tekojo
    Since I had answered a phone call the preparation was open and taking some considerable time.

    I had noticed the sync problem and here is a screen shot
    The update circle of the forum page was circling for a while. I had stopped it in the browser and pressed the update button there.

    It was not the first time, this happened to me. At other times the post was considerably less time open.


  • administrators

    @koahnig @Chris-Kawa @swegmann
    We switched on a more sensible connection handling system about 8 hours ago.

    If you still see these events, please tell here immediately (because we really hope this would fix a lot of the problems we have seen).


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.