[SOLVED] CrossCompile Qt5 to Raspberry PI - eglfs plugin not found



  • Hi all!
    I have followed the instructions found at

    http://qt-project.org/wiki/RaspberryPi_Beginners_guide

    and after a lot of pain I have been able to cross compile Qt5 to the RaspberryPI.

    My problem is that after building and deploying the sample project found on that page, it does not execute, with message:
    "Cannot find or load eglfs plugin. Available plugins are linuxfb, minimal, offscreen".

    I have navigated to the folder where the plugins are, and, in fact, there is no eglfs plugin.

    How can I generate it? I have tried several different switches in the "configure" command when building qtbase, but none has been successful.

    Any help is appreciated.
    Best regards,
    LoPiTaL


  • Lifetime Qt Champion

    Hi,

    Since it didn't build, it means that the configure test failed. Run configure again and pass the -eglfs option as well as -v you'll see were it and what is missing



  • Thank you! After passing those options, the configure utility told me the error and after struggling a bit I have been able to cross-compile Qt and execute my application correctly.

    Now I am facing a different problem: my application is opened maximized, and it does not handle any keyboard nor mouse inputs.

    I am opening a new thread for this new problem, at http://qt-project.org/forums/viewthread/52355/

    Best regards,
    LoPiTaL


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.