Qt Embedded Application not receiving touch events correctly [solved]



  • Hardware Platform: TI AM335x
    Software Platform Arago embedded linux, Root File System generated from buildroot
    Qt Dependencies: Copied over from a previous file system provided by TI
    Qt Version: 4.8.4

    I'm able to verify that the touch screen is indeed working correctly using ts_calibrate and ts_test. When I launch the Qt application however I see that while the Application does pick up touch events, it does not seem to be calibrated at all. Moreover the inconsistency of the inaccurate touch response, makes me question if this is even a calibration issue. I have already gone over setting up the environment variables several times, and I'm certain that they are all done properly.


  • Lifetime Qt Champion

    Hi,

    Just a quick idea, are you sure the application is using the same resolution as your screen ?



  • Yes, all the Widgets are fixed to 800*480.


  • Lifetime Qt Champion

    But are you sure the application itself uses that resolution when started ?



  • Not entirely sure I understand your question. I have a 7inch touch-screen display with a mazimum resolution of 800x480. When I start the application, it makes complete use of the screen space.

    I have to add that I don't see the touchscreen issue on the file system provided by the manufacturer. But the one generated by buildroot does not seem to be working for whatever reason. I also tried building Qt from source and copying over dependencies to the file system. The visuals appear fine, but the touchscreen is still not responding correctly.



  • Have you ever calibrated touchscreen on generated system?



  • Yes, right after I run ts_calibrate, I run ts_test.
    Both are applications from tslib and they work fine.


  • Lifetime Qt Champion

    Just to be sure I understand correctly, the Qt 4.8.4 from TI is working fine but not your self-built version ?



  • That's correct.


  • Lifetime Qt Champion

    The you should check with them if they did any customization for their device



  • I was finally able to resolve this by building Qt and tslib from source and copied them over to a fresh file system which didn't already have Qt and tslib installed.

    Not entirely happy with this solution, but I guess it would do. I'll have to take a look at what buildroot is doing differently when it builds qt.

    [quote author="SGaist" date="1421800119"]The you should check with them if they did any customization for their device[/quote]


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.