5.4 final - Andoid examples not running



  • Hi,
    i just opened an example from 5.4. final for android...
    For every example i tried i get the same error:

    @cp -f "libtodos.so" "C:/Qt/Examples/Qt-5.4/enginio/quick/build-todos-Android_for_armeabi_v7a_GCC_4_9_Qt_5_4_0-Debug/android-build/libs/armeabi-v7a/libtodos.so"
    19:23:02: The process "C:\Qt\Tools\mingw491_32\bin\mingw32-make.exe" exited normally.
    19:23:02: Starting: "C:\Qt\5.4\android_armv7\bin\androiddeployqt.exe" --input C:/Qt/Examples/Qt-5.4/enginio/quick/build-todos-Android_for_armeabi_v7a_GCC_4_9_Qt_5_4_0-Debug/android-libtodos.so-deployment-settings.json --output C:/Qt/Examples/Qt-5.4/enginio/quick/build-todos-Android_for_armeabi_v7a_GCC_4_9_Qt_5_4_0-Debug/android-build --deployment bundled --android-platform android-21 --jdk "C:/Program Files/Java/jdk1.8.0_25" --ant C:/DEVELOPMENT/android/apache-ant-1.9.4/bin/ant.bat
    The system cannot find the path specified.
    Generating Android Package
    Input file: C:/Qt/Examples/Qt-5.4/enginio/quick/build-todos-Android_for_armeabi_v7a_GCC_4_9_Qt_5_4_0-Debug/android-libtodos.so-deployment-settings.json
    Output directory: C:/Qt/Examples/Qt-5.4/enginio/quick/build-todos-Android_for_armeabi_v7a_GCC_4_9_Qt_5_4_0-Debug/android-build/
    Application binary: C:/Qt/Examples/Qt-5.4/enginio/quick/build-todos-Android_for_armeabi_v7a_GCC_4_9_Qt_5_4_0-Debug/libtodos.so
    Android build platform: android-21
    Install to device: No
    Building the android package failed!
    -- For more information, run this command with --verbose.
    19:23:04: The process "C:\Qt\5.4\android_armv7\bin\androiddeployqt.exe" exited with code 14.
    Error while building/deploying project todos (kit: Android for armeabi-v7a (GCC 4.9, Qt 5.4.0))
    When executing step "Build Android APK"
    19:23:04: Elapsed time: 00:05.@

    Any ideas what's wrong?

    I use windows 8.1 64 bit. And i installed 64 bit java, sdk + ndk...

    Greetings
    Nando



  • damn....
    i moved my ant to another partition...
    No error or red marking in Qt Creator Options Dialog when ADT path is invalid... That is the reason why i didn't noticed it...
    Nando


  • Lifetime Qt Champion

    Hi,

    That could be something you could suggest as a feature request on the "bug tracker":https://bugreports.qt.io/


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.