[SOLVED] Installation issues may have caused problems with kits



  • Hello, I've just stepped on QML, and need to make a hello world and some practices via QT Creator. Yesterday I downloaded the "QT Online Installer for Windows (14Mb)":http://download.qt-project.org/official_releases/online_installers/qt-opensource-windows-x86-1.6.0-5-online.exe, and when finishing installation I had to "Ignore" some errors in order the installation to be finished. Unfortunatelly I didn't write them down.

    When I open the program and start a new project everything looks normal and working, but when I try to run a hello world example, I got this message: QT Creator needs a compiler set up to build. Configure compiler in the kit options.

    When I go there, I can see some errors (screenshot attached), problems with Auto-detected kits. I guess the installation issues are related to these errors.

    I'm totally new to QT, compilers, etc, and I'm really lost. I guess I should reinstall the kits, but I would appreciate a little help to find the way.

    Thank you all!

    !http://imageshack.com/a/img537/1447/OYnOKW.png(QT KIT PROBLEMS)!


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Silly question but since you installed the VS2010 version, did you first install Visual Studio 2010 ?

    Also note that you are using an outdated version of Qt, currently 5.4 is in beta stage



  • Ouch. I just downloaded what I thought was the last version, through the site: http://qt-project.org/downloads

    I haven't Visual Studio 2010.

    What should I download to start practicing with QT Creator the easy way?

    Thank you very much for your help


  • Lifetime Qt Champion

    Then remove all of that and use the MinGW version, it has all what you need to get started.

    Current Qt version is 5.3.2



  • Thank you very much for your invaluable help. I'm downloading:
    "Qt 5.3.2 for Windows 32-bit MinGW 4.8.2, OpenGL, 737 MB":http://download.qt-project.org/official_releases/qt/5.3/5.3.2/qt-opensource-windows-x86-mingw482_opengl-5.3.2.exe



  • Hello. It still doesn't work. Dont know why.
    After installing MinGW version, I got these messages when trying to run my hello world example.

    @Starting H:\QT-PROJECTS\build-hello-world-Desktop_Qt_5_3_MinGW_32bit-Debug\debug\hello-world.exe...
    QML debugging is enabled. Only use this in a safe environment.
    getProcAddress: Unable to resolve 'glGenBuffers'
    getProcAddress: Unable to resolve 'glGenBuffersOES'
    getProcAddress: Unable to resolve 'glGenBuffersARB'
    getProcAddress: Unable to resolve 'glGenBuffersEXT'
    QOpenGLBuffer::bind(): buffer not created
    QOpenGLBuffer::allocate(): buffer not created
    QOpenGLBuffer::release(): buffer not created
    getProcAddress: Unable to resolve 'glBindFramebuffer'
    getProcAddress: Unable to resolve 'glBindFramebufferOES'
    getProcAddress: Unable to resolve 'glBindFramebufferARB'
    getProcAddress: Unable to resolve 'glBindFramebufferEXT'
    getProcAddress: Unable to resolve 'glBindBuffer'
    getProcAddress: Unable to resolve 'glBindBufferOES'
    getProcAddress: Unable to resolve 'glBindBufferARB'
    getProcAddress: Unable to resolve 'glBindBufferEXT'
    getProcAddress: Unable to resolve 'glBindBuffer'
    getProcAddress: Unable to resolve 'glBindBufferOES'
    getProcAddress: Unable to resolve 'glBindBufferARB'
    getProcAddress: Unable to resolve 'glBindBufferEXT'
    getProcAddress: Unable to resolve 'glDeleteBuffers'
    getProcAddress: Unable to resolve 'glDeleteBuffersOES'
    getProcAddress: Unable to resolve 'glDeleteBuffersARB'
    getProcAddress: Unable to resolve 'glDeleteBuffersEXT'
    H:\QT-PROJECTS\build-hello-world-Desktop_Qt_5_3_MinGW_32bit-Debug\debug\hello-world.exe exited with code 0@

    I'm googling about the problem. It seems something related to my graphic card driver.



  • Graphic driver updated and QT Creator working like a charm.

    Thank you very much for your help and warm welcome to devnet.


  • Lifetime Qt Champion

    Indeed, the MinGW version uses OpenGL Desktop which requires up to date drivers (or at least drivers that know how to talk recent OpenGL with your hardware)

    Happy coding !


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.