[Solved] Upgraded from Qt 5.2.1 to 5.3.1, LinuxFb is not working



  • Hi all,
    Today only i upgraded my QT (downloaded the source for 5.3.1 and cross compiled it) When i did it for QT 5.2 i used

    @-qpa -LinuxFb@

    while giving configure command.

    But when i did the same for QT 5.3.1 i am getting error:

    @
    This application failed to start because it could not find or load the Qt platform plugin "linuxfb".

    Available platform plugins are: linuxfb, minimal, offscreen.

    Reinstalling the application may fix this problem.
    Aborted (core dumped)
    @

    Kindly share your opinions.

    Thanks


  • Lifetime Qt Champion

    Hi,

    Try again setting QT_DEBUG_PLUGINS=1 to see what happens with your plugin



  • Thanks SGaist.

    When i did

    @ldd libqlinuxfb.so@

    Found that this has a dependency on

    @ libQt5Network.so.5@

    Aslo, so i placed libQt5Network.so.5 in the application folder and it worked.

    Can you please tell me why linux Framebuffer has dependency on QT Network library? How a network connection is getting into picture? is it something related to VNC?

    Thanks


  • Lifetime Qt Champion

    Right now, no I can't because it really doesn't make sense.

    Not VNC related, AFAIK, this plugin has not been ported



  • Dear SGaist, thanks for the reply. I looked into the source code and then finally found that the Makefile for LinuxFb module was having LIBS and in that QT Network shared object was given. I removed that and now it is working fine without QT Network libraries.

    Thanks :)

    Cheers!



  • SGaist, your help here has solved my issue that you've been looking into - allowing me to move on to the next few issues :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.