Important: Please read the Qt Code of Conduct -

Qt 5.3 on OS X 10.9 (cross-compiling Android)

  • Hello, I just trying to build Qt (in fact, I need to build only some modules not the whole Qt) for Android on my Mac.

    I set up $JAVA_HOME, $ANDROID_SDK_ROOT and $ANDROID_NDK_ROOT variables. Also I set up $ANDROID_API_VERSION to android-20, as I have {$ANDROID_SDK_ROOT}/platforms/android-20 directory.

    I run configure script like this:
    @./configure -xplatform android-g++ -nomake tests -nomake examples -android-ndk /Users/alexeykolikov/android-ndk-r10 -android-sdk /Users/alexeykolikov/android-sdk -android-ndk-host darwin-x86_64 -android-toolchain-version 4.8 -android-ndk-platform android-20 -skip qttranslations -skip qtwebkit -skip qtserialport -skip qtwebkit-examples -no-warnings-are-errors
    And got these results at the end of the log:
    @Running configuration tests...
    Warning: Disabling pkg-config since PKG_CONFIG_LIBDIR is not set.
    Warning: Disabling pkg-config since PKG_CONFIG_SYSROOT_DIR is not set.

    Could not determine the target architecture!
    Turn on verbose messaging (-v) to see the final report.
    STL functionality check failed! Cannot build Qt with this STL library.
    Turn on verbose messaging (-v) to /Users/alexeykolikov/Documents/github/qt5/qtbase/configure to see the final report.
    Did someone encountered this issue?

  • Lifetime Qt Champion


    It seems that several people are getting problem with r10. You should try to contact the necessitas google group or go to the #necessitas IRC channel to may get quicker help.

    Also, have a look at the "bug report system": to see if there's something about that

  • adding -android-ndk-platform android-19 (android-19 being an installed platform in you android-ndk/platforms folder) solved this issue for me.

    it seems the default ndk-platform used is no longer supplied with current editions of the android ndk for mac os x

Log in to reply