Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QtSvg ECMAscript support



  • Hello,

    I read in the documentation that there is no ECMAscript support in the QtSvg module for Qt versions up to 4.5. Is ECMAScript supported for any version of Qt past 4.5? The information about ECMAscript seems to have disappeared from the documentation starting with 4.6

    Qt 4.5 documentation:

    http://doc.qt.digia.com/4.5/qtsvg.html

    Thanks


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    The text has moved, search for "Rendering SVG files" and you'll find it again. However it has not changed.

    IIRC, If you want a full-blown svg parser you would need to use QtWebKit


Log in to reply