Qt Creator for Android : No platform plugin, neither libqtforandroid.so or libqtforandroidGL.so, included in package. Please include one.(Solved)



  • Hi,

    I got an issue with qt creator :

    When I try to deploy to the device, it shows the error message :

    No platform plugin, neither libqtforandroid.so or libqtforandroidGL.so, included in package. Please include one.

    What should I do ?

    Thnx in advance


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    What kind of project are you trying to deploy ?

    What Qt package did you install ?



  • Hi and thnx for the interest,

    I am trying a very simple qt application in roder to understand how to deploy to the android device ( I have a samsung tablet with android 4.1.2).

    I have downloaded the Qt Android 3.1 , so the latest.

    I have selected New Project->Application->QT Widgets Application , and simply i try the initial application to deploy it to the device.

    I have no issue with the compiling. The configuration is the default one, simply the one that qt creator prepares for you.

    I have changed the settings for the "Android build SDK" to androi-16, android-10, android-19 but i do not see any difference.I tried with the Qt Deploymen options, and also in advanced options, but nothing, the same message appears (i have tried with the eclipse to deploy an application, and it works, but it was java app. I want to create the app in c++ and to deploy it. Qt is very nice and for that reason i have selected it).

    In the options Additional Libraries, i tried to put a link to the libqtandroid.so, which lies on the Qt5.3.1\5.3\android_armv7\plugins\platforms\android\ but nothinfg. I tried with the options armeabi and armeabi-v7a. The same results

    The error is:

    23:30:29: Running steps for project Test3...
    23:30:29: Starting: "C:\Qt\Qt5.3.1\5.3\android_armv5\bin\qmake.exe" C:\Android\Examples\Test3\Test3.pro -r -spec android-g++ "CONFIG+=debug"
    23:30:32: The process "C:\Qt\Qt5.3.1\5.3\android_armv5\bin\qmake.exe" exited normally.
    23:30:32: Starting: "C:\Qt\Qt5.3.1\Tools\mingw482_32\bin\mingw32-make.exe"
    mingw32-make: Nothing to be done for 'first'.
    23:30:34: The process "C:\Qt\Qt5.3.1\Tools\mingw482_32\bin\mingw32-make.exe" exited normally.
    23:30:34: Removing directory C:\Android\Examples\Test3\android-build
    23:30:34: Starting: "C:\Qt\Qt5.3.1\Tools\mingw482_32\bin\mingw32-make.exe" INSTALL_ROOT="C:\Android\Examples\Test3\android-build" install
    copy /y "libTest3.so" "C:\Android\Examples\Test3\android-build\libs\armeabi\libTest3.so"
    23:30:41: The process "C:\Qt\Qt5.3.1\Tools\mingw482_32\bin\mingw32-make.exe" exited normally.
    23:30:42: Starting: "C:\Qt\Qt5.3.1\5.3\android_armv5\bin\androiddeployqt.exe" --input C:/Android/Examples/Test3/android-libTest3.so-deployment-settings.json --output C:/Android/Examples/Test3/android-build --deployment bundled --install --ant C:/Android/apache/apache/bin/ant.bat --android-platform android-10 --jdk "C:/Program Files (x86)/Java/jdk1.7.0_60" --device 410058ed94557000
    23:30:42: Pulling files necessary for debugging.
    23:30:42: Package deploy: Running command 'C:/Android/SDK/sdk/platform-tools/adb.exe -s 410058ed94557000 pull /system/bin/app_process C:/Android/Examples/Test3/app_process'.
    23:30:42: Package deploy: Running command 'C:/Android/SDK/sdk/platform-tools/adb.exe -s 410058ed94557000 pull /system/lib/libc.so C:/Android/Examples/Test3/libc.so'.
    Generating Android Package
    Input file: C:/Android/Examples/Test3/android-libTest3.so-deployment-settings.json
    Output directory: C:/Android/Examples/Test3/android-build
    Application binary: C:/Android/Examples/Test3/libTest3.so
    Android build platform: android-10
    Install to device: 410058ed94557000
    No platform plugin, neither libqtforandroid.so or libqtforandroidGL.so, included in package. Please include one.
    23:30:43: The process "C:\Qt\Qt5.3.1\5.3\android_armv5\bin\androiddeployqt.exe" exited with code 12.
    Error while building/deploying project Test3 (kit: Android für armeabi (GCC 4.8, Qt 5.3.1))
    When executing step 'Deployment auf Android-Gerät'
    23:30:43: Elapsed time: 00:14.

    I hope that you may have an answer about it.


  • Lifetime Qt Champion

    Are you sure you installed Qt for Android properly ?



  • Hi,

    It seems that everything is ok. Qt creator finds Jdk,Android sdk and ndk. I can start avd manager. I think that everything is ok. Qt creator finds my device. I suppose that there is not an additional configuration step.

    Is there any additional step ? The error is realy strange, but I tried many times, even re installing the qt from zero. The error remains the same.

    I say that I tried in windows 7 64 bit


  • Lifetime Qt Champion

    What Qt package did you download/install ?



  • I have downloaded the qt-opensource-windows-x86-android-5.3.1.exe , it is the latest. Tha java sdk and android sdk are also x86 (32 bit).


  • Lifetime Qt Champion

    If there's no libqtforandroid.so anywhere in your installation, then there's something wrong going on when installing



  • Hi,

    I managed to fix the error.

    The error appears due to the comodo antivirus , because it puts some files automaticaly into the sandbox. That produces the error. I deactivated the sandbox and it worked without an issue. I can now deploy the application to the device.

    Thanx again!!!


  • Lifetime Qt Champion

    Haaaa yes… These rascals seem to be pretty developer unfriendly…

    Glad you found out

    Since it's all working now, please update the thread title prepending [solved] so other forum users may know a solution has been found :)



  • I have the same problem, but my antivirus not at what. I have a "libqtforandroid.so" file in the "<qt_root>\Qt5_3_1\5.3\android_armv7\plugins\platforms\android" path.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.