Important: Please read the Qt Code of Conduct -

Qt Enterprise Setup For Android Problems

  • Hi,
    I've downloaded the Android SDK and NDK.
    I've gone to the Preferences Window, clicked on "Android" and set the location for Android SDK, Android NDK, and ANT location. The JDK Location was automatically found by Qt, so it's setup as well.
    Automatically create kits for Android tool chain in checked as well.

    So I create a new HelloWorld quick project, making sure it is setup for android.
    I then click the green play button and the emulator pops out.
    But that's it. The app DOES NOT run in the emulator.
    I check the error messages and found this in the General Messages:

    bq. /bin/sh: /opt/android/ndk/toolchains/arm-linux-androideabi-4.8/prebuilt/darwin-x86_64/bin/arm-linux-androideabi-gcc: No such file or directory
    Project ERROR: You need to set the ANDROID_NDK_ROOT environment variable to point to your Android NDK.
    Could not read qmake configuration file /Users/bliss/Qt/5.2.0/android_armv7/mkspecs/android-g++/qmake.conf.

    and this in the compile Output:
    bq. bq. bq. 00:15:46: Removing directory /Users/bliss/Documents/Qt_Projects/build-helloWorldQtAndroid-Android_for_armeabi_v7a_GCC_4_7_Qt_5_2_0-Release/android-build
    00:15:55: Starting: "/usr/bin/make" INSTALL_ROOT=/Users/bliss/Documents/Qt_Projects/build-helloWorldQtAndroid-Android_for_armeabi_v7a_GCC_4_7_Qt_5_2_0-Release/android-build install
    cp -f -R /Users/bliss/Documents/Qt_Projects/helloWorldQtAndroid/qml/helloWorldQtAndroid /Users/bliss/Documents/Qt_Projects/build-helloWorldQtAndroid-Android_for_armeabi_v7a_GCC_4_7_Qt_5_2_0-Release/android-build/assets/qml/
    install -m 755 -p "" "/Users/bliss/Documents/Qt_Projects/build-helloWorldQtAndroid-Android_for_armeabi_v7a_GCC_4_7_Qt_5_2_0-Release/android-build/libs/armeabi-v7a/"
    00:15:58: The process "/usr/bin/make" exited normally.
    Error while building/deploying project helloWorldQtAndroid (kit: Android for armeabi-v7a (GCC 4.7, Qt 5.2.0))
    When executing step 'Deploy to Android device'
    00:18:04: Elapsed time: 02:30.

    I guess the message in General Messages is the most crucial one.
    Pls correct me if I'm wrong...

    so my question is, how do I set ANDROID_NDK_ROOT to point to my ANDROID NDK ???
    also, aside from this, what else do I need to do to make Qt run on Android?

    Thank you very much.

  • Lifetime Qt Champion


    In Qt Creator preferences you have a tab dedicated to Android, you should check there.

    Hope it helps

  • Hi,

    I have the same problem, and everything setting right, Android_NDK, Android_SDK.

    I don't what is wrong with Qt?

Log in to reply