Need help on Cross compiling Qt 5.1.1 on Imx6



  • Hi, just need help on how could I cross compile my Qt program on IMX6. I have been following the steps I have found on forums (https://community.freescale.com/docs/DOC-94066) but honestly I was more confused. Could anyone be so kind to point me to the right direction. Like a checklist of what I should have, steps to follow, and an explanation on why(although not required but It would be a great help and deeply appreciated). I'm very new to linux and specially to embedded system development. So please take it easy on me :-D

    Thanks in advance guys :-)



  • how far did you get ?
    what kind of setup do you have ?
    do you use the freescale provided filesystem and kernel ?
    do you have the freescale cross compiler setup and running ?

    when they talk about the rootfs in the instructions at freescale they mean a complete copy of the sd card's filesystem. at the end of the cross compile it will install it onto the rootfs as well, so you just need to put it back onto the card.

    when i get back to work tomorrow, i'll go through my notes and post the ./configure parameters for my imx6 setup.. it's a bit different from the freescale filesystem, but i'm using xcb for the graphics on xwin and got almost everything running. (not 100% sure if qml 2.0 is running)



  • Hi clogwog,

    thanks for your quick response. Frankly, I'm not quite on how to answer your question. I have really no idea on what I'm doing, or If it is right way to do it(I assume it is right, because other are doing it :-D ). I'll just tell you what I have done so far, hope it can give you a much added detail.

    So here it goes:

    On the development board, I have program the image I have found on this website (http://www.embest-tech.com/community/index.php?topic=2769.0). Tested it, and fortunately it was a success. Connected it to an hdmi display and can see the light blue Windows-like layout interface.

    On the develepment pc (Host), which is running on 32 bit ubuntu 13.04. I have a running Qt 5.1.1. I can compile and run programs for desktop application. For the cross compilation, I have followed the steps on this topic (https://community.freescale.com/docs/DOC-94066) on QT5. I was able to follow steps 1-3 (which created a folder of qt5 in my directory with a bunch of folders and files inside it). And from step 4 onward, everything became confusing for me :-( Tried to read more post about it, and read something about yocto build (https://community.freescale.com/message/297775#297775) and Adeneo Embedded (https://community.freescale.com/docs/DOC-96390) made it a lot confusing.

    So far that all I was able to do after reading and trying out stuff out for myself. Unfortunately, I think I'm no where near on a solution. That's what lead me to seek help for knowledgeable peoples (just like you :-D) help to point me to the right direction, and possibly point out what I have being doing wrong.

    Hope that could give you an idea on what I have been up to. And I really do appreciate spending your time helping me out.

    Regards



  • hi eimarcos,

    i've struggled through the cross compile recently, and it was a very steep learning curve.

    i can't give you exact steps because i didn't completely document it. during the couple of weeks i was working on it , i had a couple of dead ends and had to start again. it is also dependent on the particular hardware, kernel and filesystem you have.

    first thing you will need is a cross compiler. we took the the one from freescale because our imx6 is from freescale. just make sure it works before you continue by creating a little hello world and running it on the unit. (i installed my crosscompiler in /opt/freescale/usr/local/gcc-4.6.2-glibc-2.13-linaro-multilib-2011.12/fsl-linaro-toolchain/bin/ )

    then take the sdcard out of your unit and copy the whole thing to a directory on your pc. name it rootfs or so. ( i put it in /home/tom/Downloads/qt/rootfs )

    then download the qt5.1.1 sources, extract the tar file

    @cd qtbase@

    the run configure

    i used:

    @./configure -opensource -confirm-license -icu -qt-xcb -make libs -no-pch -opengl es2 -prefix /opt/qt5.1.1-armel -device-option CROSS_COMPILE=/opt/freescale/usr/local/gcc-4.6.2-glibc-2.13-linaro-multilib-2011.12/fsl-linaro-toolchain/bin/arm-fsl-linux-gnueabi- -device imx6 -sysroot /home/tom/Downloads/qt/rootfs -no-gcc-sysroot @

    during the ./configure you will run into a lot of problems.. and it mainly has to do with missing libraries , include files, and PATH settings. i just went through them one by one by finding out which missing file can be found in what package, installing the package on my running unit (using apt-get install ) and then re-copying the card's rootfs to the pc's disk )

    getting the es2 opengl driver accepted in the ./configure was particularly hard.. but i hope your file system is already setup correctly.

    after this you can do :

    make
    and
    sudo make install

    if this works you have gone through the hardest part, you then only have to compile to non-qtbase parts, which is a lot easier because you'll have a qmake that will setup everything..



  • HI clogwog,

    You make it seems a lot easier. And how I wish it was that easy. Just like you have said "it was a very steep learning curve".

    Referring to the cross compiler part, How can I know If I had already Installed it? If not, how can install it? Based on your response I should be installing it on the unit, right? I searched the freescale website using the keyword "cross compiler", then look under "Software development tool", filtered the vendors on "freescale" only. List is showing not a single hint for cross compiler for imx6 or I just don't know what I'm looking for :-(

    Thanks in advance for your response.

    Regards!



  • ah, i see freescale now points to

    http://www.mentor.com/embedded-software/sourcery-tools/sourcery-codebench/editions/lite-edition/request?id=478dff82-62bc-44b2-afe2-4684d83b19b9&downloadlite=scblite2012&fmpath=/embedded-software/sourcery-tools/sourcery-codebench/editions/lite-edition/form

    it's a free download, i hope it's only the cross compiler, but it might include an IDE as well. i'm downloading it at the moment as well.

    i can swear i downloaded the cross compiler directly from freescale. oh well, if this doesn't work i can tar up the cross compiler from my machine.

    cross-compiling means compiling it on one architecture for another architecture. so no you wouldn't install it on the unit itself, only on your pc

    it is however always an option to try to compile it nativily on the unit using the g++ compiler (is available on your linaro filesystem using apt-get )



  • currently downloading it as of writing. It is the "arm-2013.05-24-arm-none-linux-gnueabi.bin" with a file size of 145.67MB? Its gonna take a while to download. I'll update you If I finished downloading it. Thanks you so much for you help :-D



  • i didn't run the .bin on my home computer but the arm-2013.05-24-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2 on that same page looks alright as well. the .bin might setup your environment as well.



  • Just finished downloading the files. Bad internet connection. Sigh :( I download both the bin and tar file, which one should I use. Is a bin file equivalent of an .exe file in windows? About the tar file, I'll just Google on how to extract it. Should I mimic the same directory path you have?



  • i think you can run the binary by just making it executable

    chmod +x arm-2013.05-24-arm-none-linux-gnueabi.bin
    then you can run it
    ./arm-2013.05-24-arm-none-linux-gnueabi.bin

    no need to make the same directory path as me, i think mine is in a weird location, but everyone in the department has it there..

    just keep an eye out where it installs things. if it doesn't look right just extract the tar file. and place the result somewhere where you'll remember /opt/.. or so



  • Hi,

    Finish installing the bin file using the GUI installer. Is it safe to assume I have an cross compiler installed on my host computer? Like as you said, I should check first if it is working. I have a working qt program which is compiled for pc, how to compile it for the imx6 board? and how run it onto the unit? (I mean, do I just copy the compiled file to the unit then run it like an executable file). Sorry, I'm just really new in to this stuff.



  • you can't cross compile a qt program yet, because you don't have the qt libraries cross-compiled yet. that's the whole reason of this.

    first try a simple "hello world"
    http://en.wikibooks.org/wiki/C++_Programming/Examples/Hello_world
    and instead of using g++ to compile it, use arm-none-linux-gnueabi-g++ that is located in the arm-2013.05/bin/

    you'll end up with a hello file that you can run on the imx6 board.
    you can check on your pc by checking what architecture it was build for by

    @file hello@
    and it should tell you that it is compiled for ARM

    copy it onto your imx6 machine and run it
    @./hello@

    if this all works, can you tell me the full path were arm-none-linux-gnueabi-g++ was installed on your machine ?



  • Hi,

    Sorry for the late post, I got sick and need to take a couple of days plus the weekend to recuperate. Back to the topic :D

    Oh I see, I went a little over board, just a bit exicited :-D I did what you ask me to do. I compiled a simple helloWorld (main.cpp) program and arm-none-linux-gnueabi-g++ and created an exe file(mainarm). I type "file mainarm", here's the description:

    mainarm: ELF 32-bit LSB executable, ARM, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.16, not stripped

    I copied it to the extension card of the imx6. I did go the directory of the file where it was copied, tried to run it by typing "./mainarm" but encountered an error "no such file or directory" error. Type "ls" to check if the file exist, unfortunately I can see in the directory :( Did I get it wrong ? Did I miss something? or Do I have to setup something in the board first to make it work? Thank you in advance for your reply :D

    And to answer your query(though it's still not working), the full path of arm-none-linux-gnueabi-g++ is '/home/erick/CodeSourcery/Sourcery_CodeBench_Lite_for_ARM_GNU_Linux/bin'



  • output of file looks good !

    did you transfer the file using a usb stick ? it might have lost it's executable flag (FAT file-system and linux attributes don't mix very well) .. try
    @chmod +x mainarm@
    then
    @ ./mainarm@
    again

    if that also fails do a :

    @ldd mainarm@

    and see if all libraries that your executable is linked to can be found (post reply here)



  • Hi,

    Already done the two steps you mentioned. The first step didn't work. and on the second step it displayed an error "Not a dynamic executable" (currently looking up at google to know what does mean :-D ).

    What should I do next? Thanks

    On a side note:
    Tried also "file mainarm" and it return an error "no such file or directory"



  • whoa..!!

    does
    @file mainarm@
    tell you anything else on the imx6 machine?
    what does file on any other existing binary (one that you can run) on your card say ?

    how about an ldd on an existing binary on your card ? does that work ?
    i'm clutching at straws here. anyone else have an idea whats going on here ?



  • Hi,

    Here are the steps I have done after compiling the main.cpp using the arm-none-linux-gnueabi-g++. I named it "mainarm". And compiled another using the standard g++ compiler, I named it "main"

    1. From the host ( verified both the file info and shared library dependencies ):

    from the command file:

    main:
    main: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.24, BuildID[sha1]=0xf1b6a3f9a35639d7ff2cce0b8337f51ed9891dc5, not stripped

    mainarm:
    mainarm: ELF 32-bit LSB executable, ARM, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.16, not stripped

    from the command ldd:

    main:
    linux-gate.so.1 => (0xb777f000)
    libstdc++.so.6 => /usr/lib/i386-linux-gnu/libstdc++.so.6 (0xb767e000)
    libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xb74ca000)
    libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xb7486000)
    /lib/ld-linux.so.2 (0xb7780000)
    libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xb7469000)

    mainarm:
    not a dynamic executable

    1. From the imx6 device:

    from the command file:

    for both files it displayed an error "command not found"

    from the command ldd:

    for both files it displayed an error "not a dynamic executable"



  • wouldn't have thought that a g++ compiled program would do anything on the imx6. it's the wrong architecture, so that's not a surprise

    what do you see when you do

    file /bin/touch
    and
    ldd /bin/touch

    on the imx6 ?



  • perhaps file is not installedo n your imx6 ?
    what does it say when you run:

    which file

    on the imx6 ?



  • Hi,

    when I type (on the imx6)

    • file /bin/touch it returned :
      "command not found"

    • ldd /bin/touch it returned:
      "librt.so.l => /lib/arm-linux-gnueabihf/librt.so.l (0x2acd9000)
      libc.so.6 => /lib/arm-linux-gnueabihf/libc.so6 (0x2ace7800)
      /lob/ld-linux-armhf.so.3 (0x2abld880)
      libpthread.so.0 => /lib/arm-linux-gnueabihf/libpthread.so.0 (0x2ab62000)"

    -with "which file" nothing happens

    Well I think file is not installed on the imx(as you suggested). how could I install it? I tried to connect it with a network cable and open up the chrome browser(which is built in), it can't browse the net. Also tried to ping my computer, it can't see it in the network. But on the system preference it shows a "wired connection"

    And what does this mean?
    "wouldn’t have thought that a g++ compiled program would do anything on the imx6. it’s the wrong architecture, so that’s not a surprise_" --- does it imply I used the wrong compiler? should I use a different one? what should I use? Sorry, I'm a little bit confuse on whats happening :-( or just referring to other file I compiled with the standard g++ compiler



  • Hi,

    Well I'm just guessing, could it be possible I'm using a different image for imx6 that making me encounter different errors. If it's not too much to ask, could you give me information what image are you using on your board and where to download it? So I can install and run it to my board. Thanks in advance :-D



  • Hi,

    Who would have thought my hunch was right. I downloaded a different image for imx6 and installed it to the unit. Seems everything is working as expected.

    When typing "file mainarm" it displays :

    mainarm: ELF 32-bit LSB executable, ARM, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.16, not stripped

    and on "ldd mainarm" shows:

    libstdc++.so.6 => /usr/lib/arm-linux-gnueabi/libstdc++.so.6 (0x2acc4000)
    libm.so.6 => /lib/arm-linux-gnueabi/libm.so.6 (0x2abea000)
    libgcc_s.so.1 => /lib/arm-linux-gnueabi/libgcc_s.so.1 (0x2ab08000)
    libc.so.6 => /lib/arm-linux-gnueabi/libc.so.6 (0x2ad6f000)
    /lib/ld-linux.so.3 (0x2aae3000)

    tried the file by typing "./mainarm", the program works!

    So what's next? :-D



  • ah good good.
    now here comes the time-consuming part:

    take the sd card out and copy everything (cp -r ) from the card to a directory on your local machine. put it somewhere under a directory called rootfs or so
    for example /home/erick/projects/rootfs/

    this is because the cross compile will be for that particular setup and it needs all the include files and libraries on that card. we will be copying this card a few times as we find out missing libraries (in lib packages) and header files (in lib-dev packages)

    go to your qt 5.1.1 source directory and cd into qtbase
    then run ./configure

    and keep in mind that this will take a while to get right

    @cd qtbase
    ./configure -opensource -confirm-license -icu -qt-xcb -make libs -no-pch -opengl es2 -prefix /opt/qt5.1.1-armel -device-option CROSS_COMPILE=/home/erick/CodeSourcery/Sourcery_CodeBench_Lite_for_ARM_GNU_Linux/bin/arm-fsl-linux-gnueabi- -device imx6 -sysroot /home/erick/projects/rootfs/ -no-gcc-sysroot@

    and i am expecting a lot of errors, so don't worry yet.



  • So I assume this will be the hard part and as you said its time consuming, so I better be get started :-D

    Before I proceed, can I make one clarification first. On my system, I think theres two qt programs (I'm assuming they are not the same because one is on a qt5 folder and the other is Qt5.1.1)

    I got Qt5.1.1 from http://qt-project.org/downloads using the file "Qt 5.1.1 for Linux 32-bit (417 MB) " to install it(which is a GUI installer and I use default setting for installing) which created a folder on my system ( '/home/erick/Qt5.1.1')

    I got qt5 from following this procedure:(https://community.freescale.com/docs/DOC-94066)

    QT5

    These steps are performed on the host

    1. Download the git respository for qt5:

      $ git clone git://gitorious.org/qt/qt5.git qt5

      $ cd qt5

    Let us consider this as <QTDir> 
    
    1. Create a build directory to install for the qt5 packages. This directory can be in any loctation. For example,

      $ sudo mkdir /opt/qt5

      $ sudo chown -R <username> /opt/qt5

    Let us consider the the installdir as /opt/qt5

    1. Enter the Qt5 directory and run the init-repository script to download all the source code for
      Qt5. To download all the source code will take about an hour.

      $ ./init-repository

      Update: In the latest Qt5 release the webkit library is included by default and there are some issues trying to compile it.

      use the next line to avoid problems if not desired to use webkit.

      $ ./init-repository --no-webkit
      ===============================================================

    which created a folder on my system (/home/erick/qt5).

    Now the problem is, you mentioned
    "go to your qt 5.1.1 source directory and cd into qtbase
    then run ./configure"

    I can't find "configure" file nor the "qtbase" folder on the Qt5.1.1 folder. But it can be found on the qt5 folder (both the qtbase folder and configure file). Logically, I should pick the qt5 folder because it has the component, and run configure (right?) Would it be a problem in the future (assuming I got the correct configuration), that I have only an installation of qt creator for Qt5.1.1 and not for qt5? Can't find also qtcreator on the qt5 folder :-(

    on a side note:

    both folders(Qt5.1.1 and qt5) contains the files "qeglfshooks_imx6.cpp, qmake.conf, and qplatformdefs.h" though in different paths.

    on the qt5 folder it can be found on '/home/erick/qt5/qtbase/mkspecs/devices/linux-imx6-g++'

    on the Qt5.1.1 folder it can be found on '/home/erick/Qt5.1.1/5.1.1/gcc/mkspecs/devices/linux-imx6-g++'

    I know this is quite a reading, and I do apologize. I just want you to a have a big and clear picture of what's going on over at my part. I really do appreciate the time and effort your putting out in order to help me. Again, Thank you very very much :-D



  • the binary (GUI) installer was for your local machine ( intel 32 bit) so we'll ignore that one, we need the sources

    after you do a
    git clone git://gitorious.org/qt/qt5.git qt5

    and look in the qtbase directory, you'll probably see that it is completely empty.. they (recently ?) split up all the subprojects into stand alone git projects...
    so just go to the /opt/qt5 directory (do a "git pull" to get the latest version )
    then also checkout qtbase
    git clone git://gitorious.org/qt/qtbase.git

    after that you should see the configure script appear in qtbase.



  • Ok got it. Ignorning the GUI installed qt.

    git clone git://gitorious.org/qt/qt5.git qt5 - DONE
    and yes the '/home/erick/qt5/qtbase' folder is empty.

    entered the directory /opt/qt5 folder,
    did "git clone git://gitorious.org/qt/qtbase.git". And now I can see a "configure" file and "configure.bat" file in the directory under /opt/qt5/qtbase.

    should I do these now:

    cd qtbase
    ./configure - opensource - confirm-license - icu - qt- xcb - make libs - no-pch - opengl es2 - prefix /opt/qt5.1.1-armel - device-option CROSS_COMPILE=/home/erick/CodeSourcery/Sourcery_CodeBench_Lite_for_ARM_GNU_Linux/bin/arm-fsl-linux-gnueabi- -device imx6 -sysroot /home/erick/projects/rootfs/ -no-gcc-sysroot

    how about "-prefix /opt/qt5.1.1-armel -device-option" I assume its pertaining to a directory in which I know I don't have. Or should I just type everything as you instructed.



  • -prefix /opt/qt5.1.1-armel

    is where the make install (at the end of all this) will install your cross-compiled qt (on your rootfs )

    additional it is also where the make install will install the qmake on your local machine that you will need for cross-compiling

    it doesn't matter what you call it, i just called it qt5.1.1-armel because i also have natively compiled versions of qt on my disk, this way i know which is which.

    isn't it working ?



  • Currently copying files from the sd card to the host compuater. I'm having a problem with limited storage on my drive. Would it matter if instead I copy it to "/home/erick/projects/rootfs/" I would put it to an additional drive. the path would be "/media/erick/Development-Files/iMx6Files/rootfs' then I would put it as the sysroot directory when Im in the configuring procedure?



  • I have run the configure file almost exactly the same as your parameters except with the directory path for sysroot. I have encountered this error:

    "Running configuration tests...
    Failed to process makespec for platform 'devices/linux-imx6-g++'
    Turn on verbose messaging (-v) to see the final report."

    As you expected :-D



  • hi,

    I managed to fix the the first error problem, but another error showed up. It shows "Could not dertemined target architecture". What could that be? I have no clue :-(

    Here's the complete error message:

    This is the Qt Open Source Edition.

    You are licensed to use this software under the terms of
    the Lesser GNU General Public License (LGPL) versions 2.1.

    You have already accepted the terms of the license.

    <srcbase> = /opt/qt5/qtbase
    <outbase> = /opt/qt5/qtbase
    Creating qmake...
    make: Nothing to be done for `first'.
    Running configuration tests...
    Note: PKG_CONFIG_LIBDIR automatically set to /media/erick/Development-Files/iMx6Files/rootfs/usr/lib/pkgconfig:/media/erick/Development-Files/iMx6Files/rootfs/usr/share/pkgconfig:/media/erick/Development-Files/iMx6Files/rootfs/usr/lib/arm-none-linux-gnueabi/pkgconfig
    Note: PKG_CONFIG_SYSROOT_DIR automatically set to /media/erick/Development-Files/iMx6Files/rootfs

    Could not determine the target architecture!
    Turn on verbose messaging (-v) to see the final report.
    The ICU library support cannot be enabled.
    Turn on verbose messaging (-v) to ./configure to see the final report.
    If you believe this message is in error you may use the continue
    switch (-continue) to ./configure to continue.



  • Hello,

    just wanted to share my experience with wandboard-dual iMX6 and Yocto.

    The easiest way would be to just take Yocto to build your image with QtEmbedded. Freescale is delivering the following layer to add support
    https://github.com/Freescale/fsl-community-bsp-base for a couple of development boards. Even if you don't use the image itself, you will find the proper configuration to configure and cross compile Qt for the iMX6.

    So just building an image for one of the supported iMX6 development boards, and look in the log-files what bitbake did in the background would propably help you to get it running for your board as well.

    Kind Regards
    Soilworker



  • So I'm having the same problem with 5.2.1 using either the codesourcery or linaro toolchains.

    My friend and I have spent 7 hours together trying to build Qt so we can finish a project and we have searched and searched. ANY help would be so appreciated!

    using
    Sourcery CodeBench Lite 2013.11-33
    gcc-linaro-arm-linux-gnueabihf-4.8-2014.03_linux.tar
    qt-everywhere-opensource-src-5.2.1

    @./configure -opensource -confirm-license -qt-xcb -make libs -no-pch -opengl es2 -prefix /opt/Qt5.2.1 -device-option CROSS_COMPILE=/opt/CodeSourcery/G++Lite/bin/arm-none-linux-gnueabi- -device imx6 -sysroot /opt/rootfs -no-gcc-sysroot@

    @./configure -opensource -confirm-license -icu -qt-xcb -make libs -no-pch -opengl es2 -prefix /opt/Qt5.2.1 -device-option CROSS_COMPILE=/opt/Linaro/bin/arm-linux-gnueabihf- -device imx6 -sysroot /opt/rootfs -no-gcc-sysroot@

    This is the Qt Open Source Edition.

    You are licensed to use this software under the terms of
    the Lesser GNU General Public License (LGPL) versions 2.1.

    You have already accepted the terms of the license.

    Creating qmake...
    make: Nothing to be done for `first'.
    Running configuration tests...
    Warning: Disabling pkg-config since PKG_CONFIG_LIBDIR is not set.
    Note: PKG_CONFIG_SYSROOT_DIR automatically set to /opt/rootfs

    Could not determine the target architecture!
    Turn on verbose messaging (-v) to see the final report.
    The OpenGL ES 2.0 functionality test failed!
    You might need to modify the include and library search paths by editing
    QMAKE_INCDIR_OPENGL_ES2, QMAKE_LIBDIR_OPENGL_ES2 and QMAKE_LIBS_OPENGL_ES2 in
    /opt/Qt5/qtbase/mkspecs/devices/linux-imx6-g++.



  • Hi there,

    I just want to let you know, that I was able to compile QT 5.2.0 a couple a month ago with Yocto (dora) and the additional meta-qt layer. You have to get the jansa-branch of that layer. With that I was able to compile the above version and I guess Mr. Jansa already adapted it for the latest Qt Version as well.

    Of course this solution implies a bit of a knowledge of the yocto build system itself. But if you follow this guide:

    http://wiki.wandboard.org/index.php/Building_Qt5_using_yocto_on_Wandboard

    and adapt it to your target board (in case your board is supported by Yocto), this would propably the easiest way to get it running.

    Kind Regards

    Soilman



  • I changed my configure to

    @/opt/gitQt/qt5/qtbase/configure/ -opensource -confirm-license -qt-xcb -make libs -no-pch -opengl es2 -prefix /opt/Qt5.2.1 -device-option CROSS_COMPILE=/opt/Linaro/bin/arm-linux-gnueabihf- -device imx6 -sysroot /opt/rootfs -no-gcc-sysroot -developer-build -no-gtkstyle -xplatform linux-arm-gnueabi-g++@

    and that got rid of the target architecture error...

    Now this remains:

    @Warning: Disabling pkg-config since PKG_CONFIG_LIBDIR is not set.
    Note: PKG_CONFIG_SYSROOT_DIR automatically set to /opt/rootfs
    The OpenGL ES 2.0 functionality test failed!
    You might need to modify the include and library search paths by editing
    QMAKE_INCDIR_OPENGL_ES2, QMAKE_LIBDIR_OPENGL_ES2 and QMAKE_LIBS_OPENGL_ES2 in
    /opt/gitQt/qt5/qtbase/mkspecs/linux-arm-gnueabi-g++.
    @



  • edit: stupid question...



  • Hi tunahammer,

    before I started to compile Qt with the help of Yocto, I was trying it in the same you are currently doing and I ran into the same issue.

    To make this error disappear, I had to specify inside the make-spec the path to the includes and the library of opengl inside my target sysroot.

    After that I was able to get one step further.

    Kind Regards
    Soilman



  • It appears the manufacturer does not include the correct files for opengl in their sysroot for this device. Am I correct in thinking I need to download the source and compile a version of opengl es2 or is this generic enough that I could try to find someone else with a project with these for an imx6 and use theirs?



  • Hi tunahammer,

    you can either use the sysroot which is provided by freescale (on the website under downloads for imx6 - ubuntu), or you could also use the yocto build system to automatically create a sysroot for you.

    http://www.freescale.com/webapp/sps/site/prod_summary.jsp?code=i.MX6Q&fpsp=1&tab=Design_Tools_Tab#

    I tried it both ways and it was working fine.

    And yes I think you could also use a sysroot from another project like the wandboard.org which uses the imx6 as well.

    See here the important parameters for my build with yocto:
    linux-imx6-g++:

    ...

    QMAKE_INCDIR_OPENGL_ES2 += /home/linuxdev/DevStuff/poky-dora-10.0.0/fsl-community-bsp-platform/build/tmp/sysroots/wandboard-dual/usr/include
    QMAKE_LIBDIR_OPENGL_ES2 += /home/linuxdev/DevStuff/poky-dora-10.0.0/fsl-community-bsp-platform/build/tmp/sysroots/wandboard-dual/usr/lib

    ...

    IMX6_CFLAGS = -march=armv7-a -mfpu=neon -DLINUX=1 -DEGL_API_FB=1 -mfloat-abi=hard -DQT_NO_GLIB



  • I would have never ever found those files Oo

    Here they are:
    http://www.freescale.com/webapp/sps/site/prod_summary.jsp?code=i.MX6Q&fpsp=1&tab=Design_Tools_Tab#
    Software Development Tools (15)
    Set of applications for the Linux L3.0.35_4.1.0 BSP

    /Vivante_VDK-v1.4.6/Linux L3.0.35_4.1.0 GPU Driver with vprofiler/drivers



  • Soilworker,

    I'm moving to a new thread since it's probably more fitting, please follow if you can sir!

    http://qt-project.org/forums/viewthread/41158/


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.