Embedde Qt app run with unexpected fading color



  • hi every one ,
    i have some problem to execute Qt application . it has just already ran & recognized all input devises such as touch screen (tslib worked correctly) , but i have unexpected fading color , i cant see any thing from lcd but just very pale object & widget in there,
    first i'd think my Fb driver had any bug , but when i used (fbv /address/foo.png) it worked correctly , just Qt app dont have clearly color , some tests in (fbtest) was didn'i shoe clearly , too . what's the problem ?


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Without any information about your board it's pretty much impossible to tell you what could be wrong. If fbtest also has problem then you should first look in that direction



  • @ SGaist
    thx for your attention , i have mini2440 with Pentronix BSP , i made my rootfs by PTXdist & qt-everywhere-4.8.4 library , when i used 8bpp foo.png to verbose to lcd -> (by : fbv foo.png) i saw that pic clearly , but when i execute Qt app or verbose a 24bpp pic to FB , i had a white view , but when i sew lcd from very sharp angel , i see some pale widget or window that i made them by Qtcreator , .... configure file had been made by PTXdist by these options :

    #!/bin/sh
    if [ "$#" -gt 0 ]; then
    STRIP='strip' /home/ehsan/platform-mini2440/build-target/qt-everywhere-opensource-src-4.8.4/configure -opensource -confirm-license -release -no-rpath -no-fast -no-sql-ibase -no-sql-mysql -no-sql-odbc -no-sql-psql -no-sql-sqlite2 -no-qt3support -no-mmx -no-3dnow -no-sse -no-sse2 -no-sse3 -no-ssse3 -no-sse4.1 -no-sse4.2 -no-avx -no-optimized-qmake -no-nis -no-cups -no-pch -reduce-relocations -force-pkg-config -prefix /usr -no-armfpa -make libs -nomake docs -little-endian -embedded arm -qt-decoration-styled -depths all -xplatform qws/linux-ptx-g++ -I/home/ehsan/platform-mini2440/sysroot-target/usr/include/freetype2 -iconv -largefile -xmlpatterns -exceptions -webkit -script -scripttools -svg -script -declarative -qt-gfx-linuxfb -qt-gfx-transformed -qt-gfx-vnc -qt-gfx-multiscreen -qt-kbd-tty -qt-kbd-linuxinput -qt-mouse-pc -qt-mouse-linuxinput -qt-mouse-tslib -qt-libmng -qt-libtiff -qt-sql-sqlite -system-libpng -system-libjpeg -system-zlib -system-freetype -no-accessibility -no-neon -no-gfx-directfb -no-gfx-qvfb -no-kbd-qvfb -no-mouse-linuxtp -no-mouse-qvfb -no-gif -no-stl -no-glib -no-openssl -no-egl -no-multimedia -no-audio-backend -no-phonon -no-phonon-backend -no-qdbus -no-opengl -shared -make tools -make examples -make demos "$@"
    else
    STRIP='strip' /home/ehsan/platform-mini2440/build-target/qt-everywhere-opensource-src-4.8.4/configure -opensource -confirm-license -release -no-rpath -no-fast -no-sql-ibase -no-sql-mysql -no-sql-odbc -no-sql-psql -no-sql-sqlite2 -no-qt3support -no-mmx -no-3dnow -no-sse -no-sse2 -no-sse3 -no-ssse3 -no-sse4.1 -no-sse4.2 -no-avx -no-optimized-qmake -no-nis -no-cups -no-pch -reduce-relocations -force-pkg-config -prefix /usr -no-armfpa -make libs -nomake docs -little-endian -embedded arm -qt-decoration-styled -depths all -xplatform qws/linux-ptx-g++ -I/home/ehsan/platform-mini2440/sysroot-target/usr/include/freetype2 -iconv -largefile -xmlpatterns -exceptions -webkit -script -scripttools -svg -script -declarative -qt-gfx-linuxfb -qt-gfx-transformed -qt-gfx-vnc -qt-gfx-multiscreen -qt-kbd-tty -qt-kbd-linuxinput -qt-mouse-pc -qt-mouse-linuxinput -qt-mouse-tslib -qt-libmng -qt-libtiff -qt-sql-sqlite -system-libpng -system-libjpeg -system-zlib -system-freetype -no-accessibility -no-neon -no-gfx-directfb -no-gfx-qvfb -no-kbd-qvfb -no-mouse-linuxtp -no-mouse-qvfb -no-gif -no-stl -no-glib -no-openssl -no-egl -no-multimedia -no-audio-backend -no-phonon -no-phonon-backend -no-qdbus -no-opengl -shared -make tools -make examples -make demos
    fi

    but also all of fbtests have some problem when run ,


  • Lifetime Qt Champion

    You should then try to contact Pengutronix about this, they might already be aware of that



  • ok , thanks , i'll try it ,


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.