This does not seem to be a "Debug" build



  • I'm trying to use a debugger with an android device and get the window with such warning message:
    @
    This does not seem to be a "Debug" build.
    Setting breakpoints by file name and line number may fail.

    Section .debug_info: Not found.
    Section .debug_abbrev: Not found.
    Section .debug_line: Not found.
    Section .debug_str: Not found.
    Section .debug_loc: Not found.
    Section .debug_range: Not found.
    Section .gdb_index: Not found.
    Section .note.gnu.build-id: Not found.
    Section .gnu.hash: Not found.
    Section .gnu_debuglink: Not found.
    @

    I'm using the Qt Creator 2.8.1 based on Qt 5.1.1 (GCC 4.6.1, 64 bit).
    The Qt libraries, the application and all the depends was built with the GCC 4.8.

    The most strange in this situation that I can use a debugger for the main Application, but all libraries are not able for debugging.



  • The problem was solved by changing the library type from dynamic to static.
    Maybe someone knows why the dynamic libraries are not able for debugging?



  • I'm still seeing this with Qt5.3.

    How did you set to use static? did you rebuild Qt yourself?



  • I didn't mean Qt. I told about my libraries. When they were static I could use the debugger.

    But right now (at version Qt 5.3.1 and Creator 3.2.1) I can use debugger in my libraries even when they are shared.

    I rebuilt Qt several times, but only for changing qreal type to double precision and never used it as static.



  • I'm still seeing this issue on mac with all the latest Qt and creator. might be a bug?

    I don't have any libraries, just the main program.



  • A solution that worked for me was to got to project>Build settings.
    Click Run Cmake and in the cmake wizard that appears add -DCMAKE_BUILD_TYPE=Debug to the command line arguments and click Run Cmake. This sets up the build to be a debug build type


  • Moderators

    Your Qt libraries are built in Release mode. You need libraries built in Debug mode if you want to debug them.



  • @jsulm Thank you. That has solved my problem.



  • But what if I can not choose debug mode cause it does not have "debug " to select ?


  • Moderators

    @ElsonAmber Then you should add Debug configuration to your project configuration: go to "Projects/Build&Run/Build Settings", then click Add combobox and select Debug.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.