Important: Please read the Qt Code of Conduct -

Problems with GStreamer- video player (with phonon) on embedded Linux (Qt 4.8.4)

  • Thanks again

    But I didn't solve my problem yet.

    I tried ldd on my plugin ( look okay right? => /lib/ (0x4036c000) => /lib/ (0x403bb000) => /lib/ (0x40d05000) => /lib/ (0x40dfb000) => /lib/ (0x41150000) => /lib/ (0x41172000) => /lib/ (0x41244000) => /lib/ (0x412e7000) => /lib/ (0x41310000) => /lib/ (0x4144d000) => /lib/ (0x4145b000)
    /lib/ (0x2a000000)

    Btw in included the plugin, libffi and libgstreamer-0.10 like this , is that okay?

    LIBS += -L/usr/local/Trolltech/QtEmbedded-4.8.4-arm/plugins/phonon_backend/ -lphonon_gstreamer

    LIBS += -L/opt/x/lib/ -lffi -lgstreamer-0.10 -lgstbase-0.10

    I also included after i read shrikantds post libgstbase (good and bad are optional for the gstreamer aren't they?) but sadly nothing...

    I am really sorry I didn't figured it out yet...

  • Lifetime Qt Champion

    You should rather have copied your QtEmbedded in the same folders on your arm device (libs and plugins and fonts). Meaning in /usr/local/Trolltech/QtEmbbeded-4.8.4.

  • thank your I copied my libs to /usr/local/Trolltech/QtEmbedded-4.8.4/lib but my application still isn't able to find the gstreamer plugin...

  • Lifetime Qt Champion

    You also have to copy the plugins dir (at least the content that you use)

  • thanks but i already copied the complied plugin folder, the folder /usr/local/Trolltech/QtEmbedded-4.8.4/plugin I found on my development PC to my device.

  • Lifetime Qt Champion

    Just to be sure: did you made a typo here with "plugin" ? Otherwise it's "plugins"

  • jep I'm sorry that's a typo, so for examle the is copied at:

  • Lifetime Qt Champion

    Ok, then next step:
    set this
    on your command line before starting your application, that should give you the plugin loading error

  • First of all thank you very much for your help SGaist, that's really great and very nice :)

    But I tried export QT_DEBUG_PLUGINS=1 befor starting my application, but nothing special happens (i also tried on my deveopment system, nothing, too)


    ./phon -qws

    If I check that enviroment variable, it's set ...

  • Lifetime Qt Champion

    Are you running a debug or release build of your application (Right now i'm not sure whether this could change the output when using QT_DEBUG_PLUGIN) ?

  • mh I had release build but i changed to debug (CONFIG += debug) but QT_DEBUG_PLUGINS dosen't work..

  • Lifetime Qt Champion

    Do you also have the debug lib from Qt on your target ?

  • I wan't in town yesterday so I couldn't test that yesterday - sorry for that

    I'm sorry but I can't find the debug lib...I crosscompild my Qt again and added the option - debug... but no debug lib was created- and also with the libs I compiled with the debug options, the QT_DEBUG_PLUGINS dosn't work

    BTW I also set the PluginPath with QT_PLUGIN_PATH=... but that wasn't successful neither.

    Also included: qDebug()<<QLibraryInfo::location(QLibraryInfo::PluginsPath);
    It shows the correct Path("/usr/local/Trolltech/QtEmbedded-4.8.4-arm/plugins"
    ), where the plugin is installed...

  • Lifetime Qt Champion

    Did you do a clean build ?

  • Yes I did...

  • Lifetime Qt Champion

    Just to be on the safe side, did you check the output of the configure script to see if it was a debug or release build ?

  • If i checked the right file ist says DEBUG=auto, however the libs I compiled with the debug options are pretty big so I think they are build during debug build

  • Lifetime Qt Champion

    so if you call

    @QT_DEBUG_PLUGINS=1 ./myApplication -qws@

    You don't have any output ?

  • mhh I compiled everthing again und copied all libs und plugins on USB.-now the application aborted.. but may thats because of the USB and not gstreamer??

    (process:673): GLib-GObject-WARNING **: cannot register existing type 'gchar'
    GLib-GObject:ERROR:gvaluetypes.c:457:_g_value_types_init: assertion failed: (type == G_TYPE_CHAR)

    And thanks again for helping me :)

  • Lifetime Qt Champion

    It's getting strange...

    What do you mean by "because of the USB" ? What do you have exactly there ?

  • SGaist I follow this post and I have a trouble
    This is my first time working with phonon and gstreamer module actually Im triying play a simple music file.
    I use your args QT_DEBUG_PLUGINS=1 followed of my app and all it works my app is launching but no audio output. When I close the app an error is showed in the terminal

    Cannot connect to server socket err= No such file or directory
    Cannot connect to server request channel
    Jack server is not running or cannot be started

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Do you have the Jack audio server up and running ?

  • i've installed the Jack audio but a message error appears:
    needs connect to X server
    actually im working in ubuntu armhf 12.10 without desktop environment or X-server i don't know if there another way to use phonon without Jack Audio

Log in to reply