Problem building QT 4.8.4 for am335x (ARM Cortex A8)



  • Goodmorning to all,

    I hope to not start a new discussion with previous discussed matters but I've searched a lot wihtout answer.
    I'm trying to build qt:
    -qt-everywhere-opensource-src-4.8.4

    This is my qmake.conf

    #qmake configuration for building with arm-linux-gnueabihf-g++

    include(../../common/linux.conf)
    include(../../common/gcc-base-unix.conf)
    include(../../common/g++-unix.conf)
    include(../../common/qws.conf)

    #modifications to g++.conf
    QMAKE_CC = arm-linux-gnueabihf-gcc
    QMAKE_CXX = arm-linux-gnueabihf-g++
    QMAKE_LINK = arm-linux-gnueabihf-g++
    QMAKE_LINK_SHLIB = arm-linux-gnueabihf-g++

    #modifications to linux.conf
    QMAKE_AR = arm-linux-gnueabihf-ar cqs
    QMAKE_OBJCOPY = arm-linux-gnueabihf-objcopy
    QMAKE_STRIP = arm-linux-gnueabihf-strip

    load(qt_config)

    and I putted it in /qws/linux-arm-gnueabihf-g++

    my configure command is:

    ./configure -xplatform /qws/linux-arm-gnueabihf-g++ -opensource -confirm-license -static -little-endian -host-little-endian -fast -arch arm

    Configuration go fast and smooth, but when I run "make" I get

    make[1]: ingresso nella directory "/home/giuseppe/qt-everywhere-opensource-src-4.8.4/src/gui"
    /home/giuseppe/qt-everywhere-opensource-src-4.8.4/bin/uic dialogs/qprintsettingsoutput.ui -o .uic/release-shared/ui_qprintsettingsoutput.h
    make[1]: /home/giuseppe/qt-everywhere-opensource-src-4.8.4/bin/uic: comand not found
    make[1]: *** [.uic/release-shared/ui_qprintsettingsoutput.h] Error 127
    make[1]: uscita dalla directory "/home/giuseppe/qt-everywhere-opensource-src-4.8.4/src/gui"
    make: *** [sub-gui-make_default-ordered] Error 2

    I've tryed multiple ./configure combination but I get always this error.
    Any ideas?

    Thanks Giuseppe


  • Lifetime Qt Champion

    Hi,

    IIRC you do not set arch but embedded arm, and i think you also don't need to set the endian options in your case.

    Hope it helps



  • Thanks for the repy SGaist,

    When I run configure without the endian options, it give me an error and says "choose between little endian and bing endian".
    I try with -embedded arm (the reason why I'm rebuilding qt it is because the touchscreen don't work properly).



  • Hi
    I have the same problem. Did you get a solution?

    Regards,
    James



  • Yes.. I ended using buildroot to build qt.. worked at the first time.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.