[Resolvido] Qt Creator sem target Desktop no linux



  • O meu Qt creator não tem como desenvolver para desktop. so consigo criar um projeto para Mobile
    quando vou lá em novo->novo arquivo ou projeto-> e quando tento criar um projeto do tipo Qt Quick Application ou Qt Widget Project
    fica desabilitado o botão next e diz assim:

    TARGET SETUP
    No valide qt version found.
    please add a qt version in tools/option or via the maintenance tool of the SDK.

    Usu o ubuntu 11.10 tem algum comando pra instalar esses tools para desktop e tbm é preciso configurar as variaveis de ambiente?

    EDIÇÃO (anselmolsm): título alterado para indicar melhor o assunto tratado - não é plugin. (era: "Qt Creator não tem plugin para Desktop no linux")



  • Olá,

    Pelo que diz a mensagem, o QtCreator que você está usando é parte do SDK, certo? Com isso, você tem 2 opções para resolver esse problema:

    1 - Usando o SDK Maintenance tool, acessível através dos menus Help -> Start updater. Escolha Package Maneger Para instalar as libs para desktop, na árvore vá em Qt SDK -> Development Tools -> Desktop Qt -> Qt <Escolha as versões>. Em seguida, _Next _ para instalar.

    2 - Outra opção é instalar Qt empacotado pela sua distribuição. No caso do Ubuntu, apt-get install qt4 (Não sei o nome exato do pacote no Ubuntu).

    Se já tiver tudo instalado e/ou ainda assim estiver com problemas, confira as configurações via menus: Tools->Options, então nas abas Build & Run -> Qt Versions. Aí é onde estão listados todas as versões de Qt conhecidas pelo QtCreator. Pode ser que seja o caso de apenas encontrar onde está o qmake correspondente a alguma das versões destkop ou ainda adicionar uma nova entrada.

    Veja se com isso você consegue resolver o problema, qualquer coisa escreva aqui novamente ;)



  • ei mala , desinstala oq tu instalou e baixa esse
    "Qt for Linux (OFFLINE) ":http://www.developer.nokia.com/dp?uri=http://sw.nokia.com/id/8ea74da4-fec1-4277-8b26-c58cc82e204b/Qt_SDK_Lin32_offline .

    caso esteja sem net rapida pede pro felipe que ele baixa pra ti rapidinho , heheheh .



  • kkkk valeu vou tentar e digo qual deu certo.



  • Hehe, estou assumindo que vocês se conhecem e não preciso usar o poder moderador [1] para passar o trator nas mensagens :P

    [1] Lembra disso das aulas de história, hein, hein? ;)



  • Ola de novo. anselmolsm, eu e o franco nos conhecemos sim. Seguinte a primeira opção falhou logo no começo. Meu Qt creator é aversão 4.7.3 (32 bit) e no menu help não tem a opção "Start updater".
    a segunda opção eu ja tenho instalado via apt-get.
    e a terceira em Tools->Options não tem a opção "Build & Run". =/

    "olha isso não tem a opção Build & Run":http://img443.imageshack.us/img443/1237/qthelp1xn.png



  • [quote author="Renatosantos" date="1332810289"]Seguinte a primeira opção falhou logo no começo. Meu Qt creator é aversão 4.7.3 (32 bit) e no menu help não tem a opção "Start updater".
    [/quote]Hm.. ok, então está rodando o QtCreator sem ser o que vem com o SDK, daí não tem memso o "Start Updater".
    4.7.3 é versão do Qt, não do QtCreator - veja em Help->About Qt Creator.

    [quote author="Renatosantos" date="1332810289"]
    a segunda opção eu ja tenho instalado via apt-get.
    e a terceira em Tools->Options não tem a opção "Build & Run". =/
    "olha isso não tem a opção Build & Run":http://img443.imageshack.us/img443/1237/qthelp1xn.png[/quote]
    [/quote]

    Isso mudou de alguma uma versão pra cá. Aqui estou com QtCreator 2.4.1, antes a aba para configurar as versões do Qt era essa Qt4 na tela que você mandou o screenshot.



  • Olha eu de novo aqui. :)
    Instalei aqui de novo, agora tem a opção Build & Run. mais o caminho do qmake ta com um simbolo vermelho como se estivesse errado.

    ta assim o caminho :

    Manual
    Qt in PATH /usr/bin/qmake-qt4.

    como posso saber o caminho do qmake?



  • Hm... parece certo, pelo que lembro Ubuntu renomeia o qmake pra qmake-qt4. Um jeito de verificar o caminho de um comando é usar o comando which, em um terminal:

    @
    which qmake
    @

    Verificou na aba Toolchains se gcc/g++ está correto? Por coincidência, vi esse sinal vermelho hoje, mas num OS X em que o Creator não sabia onde estava o compilador.

    Abraço



  • obrigadão tava sem o caminho do gcc ai adicionei.

    /usr/bin/gcc

    consegui criar para desktop mais compilei com ctr+r deu esse erro:
    :-1: error: g++: Command not found



  • No lugar de /usb/bin/gcc, use /usr/bin/g++ ;)



  • fiz isso agora ta dando esse erro:

    Error while building project untitled (target: Desktop)
    When executing build step 'qmake'

    :(



  • Renato, a mensagem de erro é só essa? Verifique se na aba "4 Compile Output" tem mais informação.



  • olha eu de novo aqui. =/

    pois é anselmolsm obrigado pela paciencia mais esse erro é dessa aba. e nas outras 3 não da erro algum.
    Olha o print aê.

    http://img836.imageshack.us/img836/3686/qterro.png



  • Hm... droga =P (sobre a mensagem já ser da aba 4)

    Já testou criar um novo projeto e compila-lo?

    Pelos seus posts dá pra ver que você está com o Qt instalado no sistema, assim é bem direto fazer um teste no terminal. Vá até o diretório do prjeto e execute
    @ qmake && make@

    Caso o qmake e a compilação ocorram com sucesso, então o problema é em alguma configuração do Creator. Caso falhe, coloque o erro aqui para verificarmos.



  • o/

    O problema é alguma configuração do Creator.
    Olha isso. :)

    http://img838.imageshack.us/img838/4113/projetoqt.png



  • Isso tudo acontece com quem usa Linux !!! :P



  • Sem flames [1], por favor.

    [1] http://pt.wikipedia.org/wiki/Flamewar



  • Estou na tentativa e erro, pois não consegui reproduzir esse cenário aqui.
    Com mais informações, ajuda (ex: fez o teste que sugeri, criando outro projeto?).

    Onde está compilando o projeto? No próprio diretório ou está usando um diretório separado para a compilação (em Projects, na barra lateral, opção shadow build. O diretório indicado em Build directory). Faça o teste também desmarcando shadow build.

    EDIÇÃO: Faltou dizer: a pergunta sobre o diretório onde está compilando é para verificar se por algum motivo estranho a configuração do seu creator não está tentado compilar em um diretório que você não tem permissão. Algo parecido com o que foi discutido nesse tópico do fórum em Inglês: http://qt-project.org/forums/viewthread/1983



  • Blza que vc é moderador e tudo , mais tenta ser menos chato , programar não quer dizer que a pessoa vai ser politicamente correta .estou apenas brincando com ele , e como não tem oq se fazer no momento pra resolver , brinquei com ele , segunda feira se ele trouxe o notebook dele , eu arrumo esse erro e o tópico esta finalizado .



  • [quote author="francomartins" date="1333200176"]Blza que vc é moderador e tudo , mais tenta ser menos chato , programar não quer dizer que a pessoa vai ser politicamente correta .estou apenas brincando com ele , e como não tem oq se fazer no momento pra resolver , brinquei com ele , segunda feira se ele trouxe o notebook dele , eu arrumo esse erro e o tópico esta finalizado .[/quote]

    http://qt-project.org/forums/rules



  • Consegui. na aba Projects em Qt version estava com "versão invalida" e "Tool chain" e "Shadow build" estavam inativas. Dai mudei para Qt 4.7.4 (system) e as opções ficaram ativadas.
    compilei com ctrl + r e pronto executou legal. Agora sabe pq aparece esses Warning?

    (untitled:3114): Gtk-WARNING **: Não foi possível localizar a ferramenta de temas no module_path: "pixmap",

    (untitled:3114): Gtk-WARNING **: Não foi possível localizar a ferramenta de temas no module_path: "pixmap",

    (untitled:3114): Gtk-WARNING **: Não foi possível localizar a ferramenta de temas no module_path: "pixmap",

    (untitled:3114): Gtk-WARNING **: Não foi possível localizar a ferramenta de temas no module_path: "pixmap",

    *Por favor o franco é brincalhão assim. não leve muito a serio tudo o que ele diz. :)



  • [quote author="Renatosantos" date="1333203671"]Consegui. na aba Projects em Qt version estava com "versão invalida" e "Tool chain" e "Shadow build" estavam inativas. Dai mudei para Qt 4.7.4 (system) e as opções ficaram ativadas.
    compilei com ctrl + r e pronto executou legal.
    [/quote]

    \o/ Aee!

    [quote author="Renatosantos" date="1333203671"]
    Agora sabe pq aparece esses Warning?

    (untitled:3114): Gtk-WARNING **: Não foi possível localizar a ferramenta de temas no module_path: "pixmap",
    [/quote]

    Hm.. esse warning é do GTK, conjunto de bibliotecas usadas para fazer o GNOME (que parece ser o que você está usando, pelos screenshots).

    Daí você pergunta: "Por que minha aplicação Qt está retornando warning do GTK?"
    Um resumão: Qt lida internamente com as plataformas onde está rodando, para conseguir mostrar os widgets com a "cara" dessa plataforma. Daí lá embaixo, tem um trecho de código GTK ;) ... Se tiver curiosidade, dê uma olhada no código. No Qt 4, isso está em src/gui/styles.

    [quote author="Renatosantos" date="1333203671"]
    *Por favor o franco é brincalhão assim. não leve muito a serio tudo o que ele diz. :)[/quote]

    Eu também sou um tanto zé graça ;)
    Só peço que entendam o seguinte: Lá na frente, quando alguém cair nesse tópico procurando resolver problema parecido, não necessariamente saberá o que é brincadeira e o que não é. Pelo que já vi online, não custa muito para algum zézinho aparecer aqui reclamando dessa afirmação sobre o erro só acontecer no linux, entendeu?

    Mas legal, parece que vocês estão aprendendo Qt juntos, fica a recomendação: tentem também respoder perguntas (diria até pra dar uma arriscada no fórum em Inglês), a pesquisa para encontrar a solução ajuda bastante no aprendizado. Abraço. ;)



  • Tópico bem útil Renato. =]



  • So complementando, para desaparecer os warnings, basta executar o comando:

    $ sudo apt-get install gtk2-engines-pixbuf



  • gdouglas7, vc é um gênio. :)

    Deu certinho cara. tava chato a queles warning!



  • é exatamente aquilo que o anselmolsm disse, não há de que meu caro. =]


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.